Problems with weather app (GXP2170 - 1.0.9.135)


#22

actually it is very easy using the zero config templates inside a UCM or even 3cx


#23

I started with the zero config, but it seemed very clunky…


#24

truly only a few clicks needed and some pcode entries is all it takes… then any handset of the same model automatically configures with the settings …


#25

If zeroconfig could allow for a xml or txt config file upload, then it would be closer to being complete.


#26

They are working towards that, but it is what it is in the meantime.


#27

Hi folks,

some cities show “N/A Not available” in the middle of screen. for ex: Wollongong,AU or Adelaide,AU

Other cities looks normal, for ex: Canberra,AU

Do I have anything wrong in “Self-Defined City Code” ?

gxp2170 - firmware 1.0.9.135


#28

on the new GRP series, the forecasting service has been eliminated.
I suppose it is better for the disabled to avoid wasting a lot of time, rather gives the customer an external forecasting station :slight_smile:


#29

i am not editing the post code of my city.
i just write the city name like Athens or Milan or Paris.
Like that working good for me.
Grandstream i believe that use the yahoo weather mode so
search your city name and paste the name like yahoo have it here
https://www.yahoo.com/news/weather/united-states/new-york/new-york-2459115


#30

I’m using city name, not zip code.
I’ve tried Adelaide or Adelaide,AU or Adelaide,SA,AU - same result.
Still “N/A Not available” message in the middle of the screen. Though, current temperature and next days report is visible at the bottom of the screen:


#31

For Adelaide, try Salisbury, AU

Don’t know why that works and not the capitol, blame the lookup mechanism - I didn’t write it…

Kev


#32

Has anyone gotten this working aside from rolling back the firmware? I’m in the US and have a 2170 with FW version 1.0.11.2 and the weather app is broken. Tried zip codes, a P code lookup and everything else imaginable to get it working. Turned off the auto-locator as it has me in a city over 2000 miles away on the other side of the continent (auto-locator attempts to use DHCP and IP address ??? would give bogus results for me). I have that manually entered. I’m considering rolling back to 1.0.9.132 to see if that repairs it. Is it working with that version? Reading this thread leads me to believe 1.0.9.135 broke it. I’ve concluded 1.0.11.2 isn’t working.

Edit:
Rolled back to 1.0.9.132 and waiting to see if that will work with city name or zip code as someone above asked about it.

Thanks
John


#33

I will check, but pretty sure that it works in 11.02. I have a unit at the office and I will check. Auto locate is using the demarc point for the ISP. So, for instance, if you use a cable provider, they may route all the signals back to a common point or NOC (network operations center) where the signals are aggregated and then inserted into whoever’s network they use for Internet transport. So, it is really up to the network topology of the ISP and how the query flows to find you location. They may also use your IP address as seen and do a lookup which may or may not be accurate, again depending on the registration info associated to the IP.

I have some clients that are in some fairly small towns of 25K or so in population. Using auto-location, they get a larger town/city where the local ISP is rather than their specific town. Using a zip, the weather is essentially the same, but the name changed from the larger city to the local one.


#34

It’s not working with 9.132 - so I await your report on it. Tried a major city like Chicago and it was a no-go. I’m going back up to 11.02 as there’s no reason for the rollback if it didn’t fix the problem.

Edit:
Is there a TCP or UDP port that’s used for this? I’m on cable broadband and the LAN is behind a NAT firewall with router on the LAN side.

Thanks,
John


#35

The phone originates the request which should be allowed out the firewall automatically unless your firewall has to have explicit rules as to what is allowed in as well as out.


#36

I have a problem with the weather app.

When a zip code is added to the web app it shows the weather for that location only for a couple of hours then it reverts to LA.

What may be causing it to revert back?


#37

I don’t have to provide explicit rules for anything unless it needs specific ports need to be opened for access from the outside - such as a PBX needing to tie in an IP phone outside the LAN (which requires many security measures). Devices such as a TV, Blu-ray players, TiVos, a Wii and Roku are all able to pull in schedule and streaming app updates without any special ports being opened. Was wondering if uPNP or NAT-PMP support was required as that’s currently turned off and has been for eons with no ill-effects. I don’t enable anything like that unless it’s necessary. None of the other devices require it and work just fine.

Thanks,
John


#38

Where did you get the phone?


#39

Ensure you’ve got the auto location service turned off inside the phone. It’s a different setting that doesn’t show on the phone’s WX settings interface. It’s on the same admin web page in the phone though, but under a different heading:

Settings --> Web Service --> Web Service Control --> Use Auto Location Service: Yes / No

Requires logging into the phone as an admin or user to see this using a web browser and the phone’s IP address. Tried to access it from the phone screen and couldn’t find a way to see it. If you change that you must reboot the phone. I don’t know if this will fix your issue but it’s something to try. If it was enabled and disabling it doesn’t solve the problem after a few hours, it’s a good practice in general to to put experimental changes back to original settings if they don’t get the desired result.

John