Problems with spam calls

ip-communications

#1

I have the DP-715 DECT cordless phone and we get a lot of spam/ghost calls. (3 calls every 20-30 minutes or so.)

Initially the calls were from 10/101/10000/5xxxx numbers and so using the advice of the internet I changed the local SIP port to 5081.

This solves that problem and prevented the calls for a while, but now we are getting calls from the caller ‘default’ followed by 1-2 further calls with id ‘External Caller’

I looked into solving the issue by setting the ‘Allow Incoming SIP Messages from SIP Proxy Only’ option but this stops the phone from being able to make and receive calls (as the option ‘Yes (no direct IP calling if Yes)’ would seem to suggest).

Does anyone know what the proxy option is for if it disables the phone or any other way of preventing ghost calls such as these?


#2

You have the right idea.

The calls are likely coming from network traffic being translated as a call, as a result you won’t see anything in the phone systems log.
If the call is coming from the internet it would have to pass through the phone system to get to your cordless phone and thus would be in the log.

The only two ways I know of to fix it is:
Option 1
The SIP Security settings: (I use all 3 but I know not all 3 are required)(not the one you already tried)

  1. Validate Incoming Messages: Yes
  2. Check SIP User ID for Incoming INVITE: Yes
  3. Authenticate Incoming INVITE: Yes

Option 2
Put the phones in a separate vlan from the regular network traffic.


#3

Thanks for the reply.

I already had the first option set from your suggestions.
Option 2 has the same ‘no direct IP calling if Yes’ suggestion, so I will not try that one yet.
Option 3 was not set and so I have set that and will try it and see.


#4

Comments here


#5

This problem is continuing for this phone.

Are there any other solutions available.


#6