Problem with the new Version UCM61xx 1.0.18.12


#1

Hello,

I have since the UCM geupdate I have the problem that the Siptrunk no longer connects and I get only error messages with which I can do nothing.
I get the following error:

If the host is not a numeric IP address, but the port number is present in the URI, the UCM performs an A or AAAA record lookup of the domain name. If you set a domain without port number, the UCM will do a SRV record lookup.

Does anyone have the same problem?
If so, where can you fix it?
It would be great if someone could help me here.


#2

That’s not really an error, just a message.

Check fail to ban, make sure the sip provider isn’t blocked.

On the status page. What is the status on the sip trunk?

Could you attach a packet capture?


#3

Hello,
thank you for you replay.
The Fail 2 ban is disabled.
i Send you the page

2018-12-01 23:29:18
Register SIP trunk failed

Generate Alert
SIP trunk registration failed! The provider name is: telekom, host is: tcp/sip-trunk.telekom.de, username is: +493839XXXX

This ist the only massage i get.

What can i do?
:frowning:


#4

Disable the trunk.
Turn on packet capture.
Enable the trunk.
Leave it for a minute.
Stop the packet capture.
Send me the file. Or use wireshark to find the error number.

For security, your going to want to plan to reset the password if you send me the file as I’ll be able to see the password.


#5

Actually, it is better that you do not disable the trunk, just leave it as is and start the packet capture. You do not really want to alter the state that the UCM is in while the problem is occurring. By disabling and the re-enabling. you are forcing the UCM to re-attempt the register request manually and Ideally you want to be certain that the UCM is attempting to register on its own without artificially inciting the action. If you left the default values the request should come approximately every 20 seconds.

Also, you do not need to change the password if only sending a capture file. While the password will be in the messaging it will be encrypted by virtue of the nonce. The nonce is the key that allows the other end to decrypt and the nonce value changes every time a message with the credentials is transmitted. nonce = number once. Rest assured the password is not sent in the clear. I am just trying to prevent the possibility of having to contact the provider to change the password. Some providers assign it and they are the only ones who can change.

Not knowing what version you were on before the upgrade might play a factor as if an earlier version, then there have been a number of changes since, that might be responsible.


#6

Hallo,
i have make a captue File.


#7

#8

Sorry, but the capture was only 15 seconds long and showed no SIP messaging. It does show some HTTP traffic on 8089, but nothing of value.

Cab you advise how the UCM is connected into your network? Are you running router, or switch? The capture will need to run for a couple of minutes.


#9

What version did you upgrade from?
Does PBX-SIP-NAT have something listed in “external host”


#10

Also strange behavior since a few days:
UCM6104 all updates done all the time since 5 years now including the beta steps.
Most worked stable since a few FW-Versions.
So i decided to upgrade the 1.0.18.09 to the 12th Version at 17th day of September this year.
All went good since then but in the last few days there´s the behaviour, that the SIP-Trunks seem to be registered if I have a look at the Dashboard and I´m able to dial out,too but if I make an inbound call to any of the numbers, then I get a provider message “the dialed number doesn´t exist…” After reboot everything works for about 45 to 60 minutes, and there is the issue is again …
If I register a sip phone directly to the provider the phone works all the time even if UCM´s extension don´t ring anymore.
And now the provider message has gone because the directly registered phone does ring now.
After I reboot UCM again - the extensions and the separate registered phone are reachable.
But only for a while…
I did a downgrade now to the previous 09-Beta again and will have a look if it´s more reliable now.
Sometimes it sucks. New features like SendFaxMail work and the most important function loses its function after a while.
Seems as Grandstream has to remember to keep the promise and fix those important issues.
What sence makes a PBX if no phone rings and the caller thinks “perhaps this company can´t even afford to pay the providers bill? Better I have a look for someone else…”
Come on GS make it reliable… I cannot sell unreliable PBXes !

Regards Michael


#11

Hello dear people,

I could solve the problem.
I simply turned off the firewall of my router and lo and behold everything worked.

Thank you for your help :slight_smile:
Greeting


#12

Well…

I’m assuming I’m missing something but…

That sounds like you solved the problem of painting your house by burning it to the ground.

Please take no offence but, disabling your firewall is generally not considered a solution.