Problem configuring new router UCM6202 and Draytek 2762


#1

Hi Everyone. I have a confusing issue with a new router and wondered if someone may be able to help?

our UCM6202 has worked great for years, behind the ISP supplied technicolor router. from what i understand the old router forwarded port 5060 to the UCM and then a selection of media ports to my internal SIP phones.

That technicolor router has started to fail so i have replaced it with a draytek vigor 2762. Simples. hmmm. but the phones will not receive inbound calls, and outbound calls do not get inbound audio.

Swap back to the technicolour and it works fine (until it overheats again.) If I put the draytek in place and immediately the calls stop.

I have setup the same port mappings on the new router as were present on the old router. I’ve disabled SIP_ALG and otherwise mimicked settings between the routers but i cannot get it to work. even tried turning on uPnP and a DMZ to the UCM.

SIP trunks are from draytel. IP phones are cisco 2760g there are 4 internal phones all in the same IP network as the UCM.

Any ideas? I would be happy to pay someone to get this working but where should i look for an engineer?

Thanks in advance, Al


#2

Turn off UpNP and DMZ.

1st, when the Draytek is connected, do the PCs behind it have Internet?

If they do, then use the open ports and follow the following:

In the above, change the local IP to that of your UCM. Confirm the IP by seeing if you can log into it.
Change the ports I have a s 10000-10250 to match those in the RTP section of the UCM. I have cut mine down to the minimum allowed by the UCM as the UCM cannot possibly use the default 10000 port range.

You can delete the 8089 port if you like as this is the default, but I have my router set to only allow certain IPs to access and I also use the Draytek Smart VPN client.


#3

Once this is working, I would limit UDP port 5060 to only your ITSP’s server to cut down on hacking attempts.

Also, unless you are accessing the web gui remotely, I would suggest removing or restricting TCP port 8089.


#4

I will be showing that as a step when ready.


#5

Hi @lpneblett thanks for the comprehensive reply.

This seems like it should be a simple task but it’s really foxing me.

does the router work and give internet access to PCs: Yes! the vdsl settings are working fine and the router connects and gives good speed. all other functions work, including some other open ports to my CCTV box and internal web server.

I’ve tried the open ports settings you suggest, (they were not that different to my existing settings) and still no incoming calls or inbound audio on outgoing calls.

from what i can tell on the old technicolor router there was never any ports open to the ucm, only the media ports to two of my internal phones, but then all 4 internal phones work fine with the old router connected, so I’m still bamboozled. i wonder if there is any hidden config on the old technicolor machine that I cannot see using the html interface.

The system was originally commissioned by a chap met via gurus.com and although it’s worked well up to now I do wonder if he used orthodox methods.

I’ll try and upload a screen shot of the old router and new router.

Thanks again,
Al


#6


#7

There is more to it. I am using the default settings of the UCM, except for the RTP ports which as mentioned are shortened up.

The SIP trunk is it a register or peer trunk and if a register trunk, is it showing green?


#8

you’ve gone from Technicolor (a Panda Fiat) to Draytek (a sedan of value), a professional router with integrated firewall that has nothing to envy to much more expensive vendors.
Obviously a professional router like Draytek you don’t set it up for VoIP if you don’t know it.
It’s not enough 2 screens to make everything work, you need to set up ad-hoc UCM and Draytek.
You should ask for assistance, here I think many people know it, with a fair fee you will have a good functioning.
The first thing to do is to activate the rules of NAT in ACL, otherwise you will always have problems of operation and safety, I hope to have been useful.

Damiano


#9

I’ve got 5 trunks, all register trunks, and they show as blue dots on the dashboard.


#10

OK, I just PM’ed you.


#11

Thanks for your reply @damiano7
“You should ask for assistance” that’s what i’m doing here.

As you can see from my post above, the router is already functioning fine with other appliances, so i’m seeing peer support from people who are knowledgeable and helpful with grand-stream config, feel free to chip-in with any help.
Al