Prepend trunk name no longer works after firmware upgrade


#1

Hi, I noticed that prepend trunk name is no longer working after upgrading from version 10 to version 18. The setting is enabled. All I see is the phone number on Caller ID. Can anyone test whether it works for them?


#2

Working.


#3

Works for me


#4

Works for me as well. Just enabled it.
Setting “on” for all trunks perhaps?


#5

Can you be more specific on where you have the setting and what phones are receiving it?


#6

Extension / Trunk -> Inbound Routes -> select "Trunks: " -> Edit icon -> Prepend User Defined Name -> check box and fill field. Do you recommend rebooting the PBX?


#7

That’s always worth a shot if you are able to.
What phones are supposed to be receiving this info? What firmware?


#8

Rebooting did not solve the issue. Screenshot attached.


#9

A small problem, that is not the trunk name, but rather a user-defined name. The trunk name is sent when the box to the right is checked. When the box is checked, the trunk name assigned to same in the trunk settings will be sent. That is what I checked when I indicated it worked for me.

Nevertheless, I unchecked the trunk box and assigned a name to it using the user-defined box and made a test call while doing a capture. The user-defined name was not in the INVITE from the provider, but the UCM did insert the name in the INVITE sent to the phone.
It was in the From user header: “Trunk1 NEBLETT LARRY”
Trunk1 was the user-defined name assigned.

I also noticed it was sent in the RPID header. I have this turned on as well. You might go to the PBX Settings, SIP Settings, and ToS and turn on “send remote party ID” and then test to see if this helps. I would think that GS would simply prepend to the From header, but maybe they do something internal such that both settings have to be on.


#10

I see the phone number only when calling from a cell phone. Before the firmware update, it would show the trunk name as the caller. Turning on “send remote party ID” did not show a prepended name.


#11

It go to IVR, you do not have this checked ?
image


#12

I checked that box and still see only the caller’s phone number. Not the Trunk


#13

As a test. redirect from the IVR and have the call go directly to an extension and see, Then put it back to the IVR. Let us know results.

I will do same to confirm.


#14

I had no issue. Call came in, went to IVR, selection made to send to phone, TRUNK1 showed in CID on phone and softphone,

Take a network capture of call and see what shows.


#15

does the tag show up in the CDR logs

What firmware is on the phones?


#16

Yes, it does show in the CDR with all the details.

Boot: 1.0.1.2
Core: 1.0.5.9
Base: 1.0.5.16
Prog: 1.0.5.18
Locale: 1.0.5.3
Recovery: 1.0.5.12

Is it a matter of rebooting the phone, or updating the phone firmware?


#17

Well, Lucas asked first…what phone make & model? But no matter now, if not the latest released F/W, please do the update.


#18

I’m having the same problem. Prepend Trunk name or user defined, neither work. Phones (GXP2170) and UCM 6510) are both on the latest stable firmware, 1.0.9.108 and 1.0.18.2 respectively. I’m going to try the beta firmware on one of the handsets.

EDIT: Doesn’t work still with the 2170 on Beta .118 firmware. I’m not a Grandstream guru, or even a sip/voip guru, but I maintain another client’s Grandstream system (same UCM, same phones, same firmware) and it works. That’s on a PRI and not a SIP trunk, though. I think it’s probably some setting somewhere that I can’t find lol


#19

It is not the firmware on the UCM not on the phone.

Here is what is needed.

  1. Set the name on the rule.
  2. Start a network capture and make a call that will utilize that same ruie.
  3. Stop the capture and download and save.
    4, Download and install wireshark (www.wireshark.org) It will advise the release to install. Do not install the USB Pcap. Do install the pcap and a desktop icon.
  4. Locate the zip file downloaded from the UCM and unzip it so that you now have a pcap file.
    6 Double-click the pcap file which should then automatically start wireshark (WS). If not then open WS and open the pcap using the file commands within WS.
    7, Once open, then look at the top and use the Telephony tab and select VoIP Calls.
    a) This will present a listing of the various calls that were seen by the interface during the period of the capture.
    b) A call will be segmented by the origination and destination IP seen. So if a call comes in from the provider and the route sends to extension 100. Then there will be two line of info, One from the provider to the UCM and another from the UCM to the destination(s). If you have a ring group for example, then there will be a line for each destination in the ring group.
    c) Look for your call from the provider and then look for a destination and highlight both lines (if you answered the call, then look for a 200OK off to the left as this indicates the extension that took the call).
    d) Once highlighted, then look for the button for “Flow” and click same. This will reveal the top level messaging flow between the provider and UCM and then the UCM and the extension.
    e) Look for the INVITE from the UCM to the extension and once found double click the line. This will drill down to that specific message so you can see the details.
    f) Once clicked, you will need to navigate back to the original page that was opened bu WS. It is the same page that was used when you selected the tab at the top “Telephony”. The message you just selected will be presented below. It will show the INVITE from the UCM to the phone and you can then use your cursor to select and then open the various details of the call. In this case open up the Session Initiation Protocol (INVITE) line and then the line Message Headers bl clicking on the “>”. You can continue to expand the headers to get to the details in each. You are looking for the “FROM” header and then the SIP from address: User Part.

This will only be in the INVITE from the UCM to the phone as it the UCM that is pre-pending the name. It will not be seen in the provider to UCM INVITE.

If you have a provider that has multiple trunks then each trunk must also have an associated inbound route with the same naming settings.

if you see the assigned name in the message, then it is being sent to the phone and you may need to look at the phone settings for callerID and experiment.


#20

Thank you for the highly-detailed reply, that was really helpful! I was able to learn that the UCM is not sending the prepend user-defined text to the extensions. The SIP from address user part is just my ten digit cellular number (where I’m calling from) with a + sign at the beginning, which is exactly how the provider sends it. The confusing thing to me is that the UCM’s CDR shows the correct info in the “Call From” column down to the ring group, but in the extensions themselves is shows the ring group name and my call number. But at least now I know how to capture and analyze - thanks again for that.

EDIT: I disabled the “replace display name” option in the ring group, and now the CDR shows the prepend code all the way to the extension, but the phone still isn’t displaying it. But I feel like I’m getting somewhere.

EDIT2: GOT IT! It was a phone setting, after all. Under the SIP account, SIP Settings, Basic Settings, the setting “Caller ID Display” was set to Auto. I changed that to “From Header” and it shows what I need it to now. The phone I’m testing is an external extension (no zero config or template) but I’m having the same problem with the 50 or so phones on premise, so I just need to figure out how to make this same change to the model template for those phones. But the mystery has been solved for me, hopefully this will work for others, too.