Preferred vocoder had no codecs set


Grandstream GSWave

I configured an extension on a freePBX server but no codecs were being sent to the server. Preferred vocoders had no codecs set. How could that happen?

Just to clarify this, I solved the problem by enabling a couple of codecs. My question is why all of the codec settings we’re disabled?


I can’t really say. I just downloaded onto my Android (One Plus 7 Pro) and I manually configured as I suppose you did and it came up with g711u and g711a as the default codec for both Wifi and Cellular. I never set g711a as I am in the US where it is not used for the most part. So, I do not think it found g711a in any of the other softphone apps on my phone and cloned same, but I could be wrong there I do have a few and can’t say that it escaped me.

I always try and check as I never know what might be set and there are typically ones that I never use and do not care to have in the offering.


The issue is that there were no codecs selected, which caused no media to be sent. The default seems to be PCMU and PCMA.

I tried to replicate the problem by disabling all codecs but the app would not allow me to save that, warning that at least one codec must be selected.


Gremlins. The only possible answer.

I have no clue.