PMSAPI not working


#1

Im trying to test out the PMSAPI to see if I can get some features I need working however after i follow the how to I keep getting 403 forbidden. Not sure what I missed. Just trying to add room status to see it work
phonessss


#2

You generated a hash for the username/password?
You added the room and is there a reason why the address is 400 and the extension is 4800?


#3

I got it working had issues with the Permitted IPS and Microsoft trying to help me. However now I get prompted for the user name and password to run the API. Like it does not like the token. For testing I currently have the user name and password the same on both the API and PMS config. I couldn’t figure out from the manually if they need to be the same.


#4

Any thoughts as to why I still have to login to the API even with the token present?


#5

In testing, I had no such problem. Every check-in or checkout was taken without issue as long as the md5 hash token was present in the command.


#6

To verify im sending the right command its https://xxx.x.xx.xx:8443/pmsapi?token=xxxxxxxxxx&format=… Im concerned that I may not have that first portion correct. I followed the how to to a T so im not sure where I went wrong. When i made the md5 i did usernamepassword for hash no spaces or enter keys. This is the same un and password that can be found on the api config page under https api settings?
Every time I try and run a url I still am prompted for username and password. I enter the user name and password from the API config page and it works.
Also what is the username and password used for on the PMS page. I have not figured that one out yet.
Thanks


#7

https://10.10.10.110:8443/pmsapi?token=1269d012768654cc7b295685aab94395&format=xml&data=<pms_data_request><checkin><address>1100</address><room>1100</room><account>1100</account><firstname>John</firstname><lastname>Doe</lastname><language>English</language><vipcode>2</vipcode><datein>2019/11/04%2011:00</datein><dateout>2019/11/07%2013:00</dateout><credit>9999900</credit><cidnumber>11001100</cidnumber><cos>3</cos></checkin></pms_data_request>

The above worked for me. The forum formatter changes the XML apperance, but if you copy and paste the string into a broswer, the format will return correctly.

At first, I thought that perhaps I had manually logged in and that possibly the UCM cached it and no longer needed it. I made the login and password the same for all - cdrapi/cdrapi123 - as I was not interested in seeing what the differences were at the time as that could be determined later, after getting it to work. I rebooted the system and sent again, and the system accepted it to tell me it was already checked-in. It took the hash.l


#8

Thanks again,
But I am still getting the issue. Adding screen shots as Im at a lose all screen shots show what I have configured. I even used the same un/pw and took your url just chnaged the IP.




#9

Did you add rooms?


#10

Yes I had room number

I did have my web programmer also take a look he said, and I know I will butcher this. It is trying to pass the login through http on the built-in web server of Grandstream and not https. He said this can be taken care of with some php coding on our end but I would love to see it work the way its intended. Did I miss a https switch somewhere?


#11

Are you sending from a subnet different than the UCM?


#12

Yes it is going from a different subnet,


#13

Well, I tried from a different system and lo and behold, I have the same issue as you. When I submit the command, I get back the login box from the UCM.

I will play with it more later today.


#14

Thanks again. At least I know its not just me anymore.


#15

I have submitted a ticket on the issue.
We wait.