Please Upgrade to Immediately for Security Fix: Firmware for UCM6202/6204/6208/6510 Released as Official



dont release untested security fixes… there are lots of things that shouldnt be done, but they do them anyway

#42 was released on 4/6/2019. That was followed by which was released on 13/12/2019 and contained a security improvement.
All GS firmware files are in the form As far as I’m aware they don’t release .tar files.


Where did you get this file from


are you serious, where did i get it? how long have you been doing this?

, the only way to get a previous released firmware is thru the link in the release notes, that firmware was loaded because it would have been the most recent one available at that date. please see release notes for previous editions, you may need it to restore a dead cabinet… good luck


the tar is the backup in the system, you better label what version the back up is, you cant tell it says Dec 20, 2019 version


I’ve been a SIP professional for almost 20 years and been selling UCM’s since they were first released in 2013. Never ever had any issues with them.

the only way to get a previous released firmware is thru the link in the release notes,

Wrong, they can be downloaded from the GS ftp server
As I mentioned which was released on 13/12/2019 and contained a security improvement

so you really should have applied this update by 20/12/2019.
I really suggest you stop moaning and work out whats up with your units and why others have had no issues.


just because you cant smell the fire, doesnt mean its not burning… good luck using the model templates and the sim ring… hope you never realize you have an issue


First, there seems to be some confusion in the statements about the firmware and backup. To clarify, the backups are in a .tar format whereas the firmware is released in a .zip. The way in which you answered the question regarding the previous release was possibly confusing.

The backups, if performed on a schedule, do indeed contain the date:

but, if doing manually the naming convention is up to the user invoking the backup.

Finally, this is a user-to-user forum and not an official GS support mechanism. They (GS) do tend to monitor and may elect to respond to various posts, but there is no guarantee of a response other than submitting a ticket to the help desk.

As far as the issue you have experienced, I have not had any issues with any of the latter upgrades on any of the systems I have installed, to include the versions mentioned in the thread. Of these, I have had some that followed the same upgrade path as you posted as while I sell and maintain many, some clients have their IT staff handle this task after the install and I sent them emails about the updates.

This is not to say that you don’t have the issues, but I am wondering if the issues you have now are a manifestation of a problem that existed earlier and was not evident until now. As far as the templates go, I have had custom pcode settings get deleted by the system. Is this what happened to you? This one in important as it might relate to some of the other issues.

I have not experienced user lock-out either, but this may be because I use a password keeper that populates the fields for me. However, I have had on more than occasion where I manually entered the wrong one, but it always gave me the countdown and I managed to fat finger my way into it without being blacklisted.

Every user is subject to having a different experience for various reasons and like you, some have run into issue whereas others have not. As you have apparently run into some in which the user-base is unable to assist, please submit a ticket as GS can dig into the system and possible assess what the root causes are.


Hi upgraded a unit 6102 to 18.18 and ring simultaneous stopped working , strange thing is follow me worked with no issue. wireshark trace showed private ip in contact header when call was placed to the external number using ring simultaneous. Did not have time to look at it as client was happy with the follow me.

Never seen this before it one way audio only on the ring simultaneous external number. Any idea apart from sip nat settings …ideas on why follow me works and ring simultaneous not working.



Me either. That was a quote from the original duplicate post that I was commenting on.


I have responded you on private regarding the one-way audio.


Thank you I will give it a try


here is another cool feature of the bug fix


Have any of the users above that had issues with peered UCMs sort it out on 20.23? We just upgraded our first peered system to 20.23 and it immediately broke. No BLF or LDAP configured, just a simple tunnel for dialing extensions that has worked flawlessly for 4 years, until now.

The trunk status went to “Abnormal” immediately upon reboot after the upgrade (correct upgrade procedure was followed and a backup was loaded on the upgraded system after a factory reset). We are not running through a VPN nor have a firewall in front of this UCM (couldn’t talk the client into the expense sadly). No changes were made on the UCM at the far end. We do not have access to the peered UCM on the other end which isn’t ideal, but we do have an IT contact to help. Just hoping we might be able to find some guidance from others in the trenches…


Sorry @DSA240, I had not trouble with any of the systems I upgraded to 20.23 from earlier 19.x and 20.x firmware.


without Firewall, without VPN and without NAT rules in ACL is a risky installation.
If I were you I wouldn’t say, and I’m not kidding.


Maybe he skip few fw ?


We use Zero Config to set lots of options on GXP2170 phones. Since upgrading to, the VMPK “Mode” setting on all ZC templates is a number (0, 26, 11, etc) instead of “Line”, “Monitored Call Park”, “BLF”, etc. The templates still work correctly, but don’t display correctly in the template editor. We’re seeing this on several of our systems. Anyone else see a similar issue on ZC templates after upgrading to this firmware?



We have hassles here with electricity supply being faulty. Last week we had load shedding again. The resultant spike ran over the UPS and the UCM6204 that I have now has corrupted software. I have reset to factory settings and did whole new setup. Now the extensions won’t come live but the Trunk is working fine.

Can anyone advise please.

I tried to upload the latest version but get that their is a sw mismatch. I attach screenshots.





Re download the firmware file and try it again. And recommend a Factory Reset after the upgrade to clear any lingering issues with your extensions not registering.


Hi Cyfo,

I did exactly as you described. The new software does not load. I get short error message.