Phones suddenly stop ringing


I have hundreds of these phones out there, and have reported this problem to support, but I dont see this listed as a fixed or an unresolved problem even in the BETA that came out today. If a user changes their ring tone from the default, the phone will eventually stop ringing. the phone will never ring again unless you go and reset to default. This is embarrassing as my users do not understand how there could be an error this large for so long (I have been reporting it for months)


Beta Version is supposed to fix this issue its in the updated release notes.
I have just deployed it to some phones to test.

GRP261x Beta Test Firmware (


Thanks yes i f see that now. Earlier I posted this because support said it wasnt fixed yet. Let’s hope it works!!I have also deployed to about 12 phones and we will see!


Update the latest firmware did not fix the ring problem. It may have change the frequency of when the problem happens, but it is still happening


Update aswell: Confirmed did not fix it for my customer either and have reported it to support.


Dear users,

Thanks for all your feedback! I will pass the issues to our GRP261x developing team for troubleshooting. Thanks!

Thank you!


Dear user,

You can also creat a ticket in Helpdesk system and we will have technical support to review the issues asap. Thanks for your testing!

Thank you!


I have posted several helpdesk tickets on the subject and reached out here this when they couldn’t help me.

I have just created a GDMS job to reboot the phone every night. our users have had the system of months and need their phones to ring


Dear user,

Thank you for your feedback! I will pass this issue to our GRP261x development team for evaluation. Could you kindly send the ticket number to us? I will send the ticket number to the support team for evaluation. Thanks for your testing!

Thank you!


Ends in 8120414


Dear user,

Thank you for your feedback! I will pass it to our support team for evaluation. Thanks for your testing!

Thank you!


Same problem here. 2 Days ago i made the horrible mistake of updating the Firmware of my GRP2612 to Version It took me a day to notice that the phone did no longer ring when called. I could still make outgoing calls.
I could not get it to work. I tried the Beta, same problem.
I tried to downgrade back to but it did not take it. Had to go back to
Still no ringing. Nothing actually. It does not even show up in the call log, display shows nothing about an incoming call.

I read about the custom ringtones. Never used one, always system default. Tried changing it, no success.
I ended up doing a factory reset on and then it did work once. It rang when i called it.
But now, next day, it is again not ringing, no caller activity whatsoever.
Intersting fact, i can still make outgoing call, but now it does also not make a noise while dialing. there is no “free tone” or the regular sound you hear while you wait for the other side to pick up. (sorry not sure what the right term for that is in english). This is unusable. Restarting does not help. Only factoy reset for a few hours.

i did not change much at the settings. its all default except for the SIP account information. It is connected to my home router and it worked flawless before.

i would like to downgrade to or maybe or something like that.
But the first one is not accepted for the downgrade and the second one is not available anymore on the website. now i can only chose or the beta which both don’t work.

i need my phone to work.

Edit: i stand corrected. i disabled automatic firmware checks and now i was indeed able to downgrade to phone is working again. it is ringing and i have the dial tone.


So I have a lot of experience with the ringing problem as I have hundreds of these phones I support. The problem most people were having involved the phone stopping ringing after a few days Rebooting it fixed the problem for a few more days. The firmware ending in .93 still had this problem. The beta firmware ending in .104 should fix this problem, as far asI have heard. If you have a different problem (rebooting doesn’t fix) then you might open a ticket on that so they can get some logs, etc.


They STILL have not fixed the problem…I have had one variation or another with the 26xx phones starting at 5.93 to the latest version AND the beta version ring phones stop ringing. Now the issue is if you xfer a call using ANY MultiFunc key, the next incoming call will not ring, the the 2nd will and it just continues…

Been using GS for more than 10 yrs but I am about done with them, a problem that has been going on for almost a year…


I have also reported this issue to GS support a few days ago. Sent them a video with it happening. Not that it helps much but the more people that are reporting the issues the better chance we can get it resolved.


Beta firmware fixes this.


Hopefully thisis fixed for you, it works fine for us now