Phones keep ringing even after someone aswered on another phone



We have multiple customers each with a ring group that rings different brand of phones including Grandstream GRP2612W. When the call comes in and someone answers teh call, all other brand phones stop ringing but the GRP2612W phones keep ringing until someone picks up the handset and stops ringing.

We are using FreePBX 14 asterisk 13 and the Ring group is set to yes on “Mark Answered Elsewhere”.

We tried multiple tests but had no luck. We tested with firmware and but the problems didn’t go away. We set them on WiFi and tested and then switched to wired but had no luck. We changed the routers and still no luck. When a new call comes in all the phones in the ring group ring. When one of the phones answers the call all other phones stop ringing except the GRP2612W phones. All of our customers with that model of the phone have exact same problem.

We also tested calling into the group and stopping the call before anyone answered. All other brand phones stop ringing but the GRP2612W phones keep ringing!

Our customers are spread from East coast to west coast. Please advise. Thank you!


How was the phone provisioned? I assume the phone is inside the NAT, yet; it sounds like a NAT issue. Being on WiFi is the subnet to which the phone’s IP is obtained different and have you accounted for this in the FPBX firewall so that it knows the phone to be local?


Thank you for your prompt response.
The phone was provisioned initially with GDMS Template,By Model, which points to our provisioning server to download all configuration.
On the server side, all the phones of different brands are configured identically:
Nat=yes- (force_rport, comedia)
On the device side:">KeepAlive<

We removed one of the GRP2612W phones from the ring group and added to the Follow me of another phone. Same problem. Once the phone starts ringing it doesn’t stop.

We thought it should be the network that drops the SIP signal to stop ringing, but all other brands of phone stop ringing once someone answers a call. We believe the fix might be one of the parameters of the xml configuration file that misbehaves but not sure which one.


Where are the phones in relation to the PBX? Are all on the same LAN?


No. They are spread across US. We have only remote access either through GDMS or remote applications like Zoho to their computers then to their phones.

We set up a replica of one of our customers in our lab. We could replicate the problem for w while. But now for whatever reason we can’t. Maybe because we upgraded the firmware to 1.05.33 in the lab that stopped the problem. But we also upgraded the firmware of our customers to When we call our customers and after they answer the call, we hear other GRP 2612W phones still ringing; showing our number.


FYI… all the phones of each customer are located on the same LAN. Each customer has a different ISP provider and I guess different type of modem-router.


For the phones that are remote, did you set STUN as the network mode (instead of keep-alive) and set a STUN server? Then you can enable options keep alive in the SIP settings.

You may also need to get into the remote site’s router or cable modem to insure their SIP ALG is disabled.

If the site has a static public IP, then you can set a NAT IP in the phone which would be the remote site’s static public IP.

The issue is NAT and while you have installed the SIP server into the phones so the phones always know how and where to contact the PBX, the PBX does not know how to contact the phones as the phones are likely telling the PBX to use their private IP as they likely have no idea of the public IP unless you have STUN set for those with either a static or dynamic public IP or set a NAT IP for only those with a static public.

The messaging is to cancel the ring may not be seen by the phones as the PBX is sending to the private IP and, of course, the phone will never get.


At least a few of our customers have a mix of different brands of phones including GRP2612W and Yealink in teh same Ring Group. Our FreePBX servers are set up in a totally different and remote data-centers running in semi-multi-tenant mode. We have no problem with other brands of phones. Some of our customers have multiple brands of phones in the same Ring Group. All other phone behave properly but not GRP2612Ws.

I just ran another test in our lab. I called from one GRP2612W directly to another GRP2612W and hang up after one ring. No problem. Then I rang again and let it ring for 3 rings and hang up. It kept ringing on the other phone! So the problem exists except that it is more randomly in our lab than at our customers office.


sorry didn’t respond to you first question. We don’t use STUN.


Comparing one make of phone to another, is not really helpful other than to indicate that the particular make and model works in the environment whereas the other does not. It does nothing to indicate what needs to be done to fix the GS phones so that they also work.

I can only tell you that if the phone does not know its public IP, then how does the PBX know how to formulate a response that goes back to the phone? Set STUN.

I also use FPBX and have a single site with over 400 extensions, all remote save maybe 30.

You can also do a wireshark capture and look at the messaging to see how formulated which is the only sure fire way to know. If you are not familiar with how to read the capture let me know and I will try and help.


Thank you for you suggestion. Our company policy doesn’t allow us to modify customers network which will make us liable for hacks etc.
However I’ll use wireshark tonight. There is heavy traffic during the day. Is there any parameter I need to look for specifically?


Look for the contact and the connection header.

The contact is where the sending device is telling the receiving device where to send the SIP messaging.

The connection header is where the sending device is telling the receiving device what IP to use for the RTP stream.

One will be in the main body, the other is the SDP.


Thank you! I’ll try.


Unfortunately I couldn’t replicate the problem late at night. It might be due to the low network traffic.
I’m strongly advise by my supervisor not to disturb customers during daytime. The reasoning behind it is:

  • We have so many customers that use all different models of Grandstream phones but non of them have so far complaint about ringing problem except of the recent new model of GRP2612W.
  • We have also customers that use other brands of phones together with Grandstream GRP2612W phones. None of the other phone exhibit such problem. Only GRP2612W phones do.
  • Even if we could “fine-tune” the network of one of our customers such the the problem would disappears, we would run the risk of introducing other problems to the network which is otherwise finely configured and in perfect operation.
  • Everything points to the XML conflagration or the firmware of the GRP2612W phones as the culprit. One or a few parameters need to be adjusted but I don’t know why.

My supervisor was the one who was very excited about the GRP2612W phones but now he is completely pissed off. I read many other posts reporting the same problem. I can’t work on this problem by myself unless Grandstream begins testing it in their labs. I’d be glad to let Grandstream techs access my lab but it seems that the problem appears only randomly in our lab. Our customers are unfortunately off limits.

Regards. JG


Do a network capture which disturbs no one.

Sitting back and doing nothing does…well, nothing and certainly nothing to fix your or your client’s problems.


Was something ever found? We use GXP2170 across all our locations (about 170 phones) and we have zero issues. We purchased some GRP2612W for some staff that WFH and are experiencing this exact problem. They can call; audio works when calling out of the phone but not inbound, the calling end just gets ringing and ringing. We even tried upgrading to the latest firmware with no luck.