Phonebook deleting


#1

Hello,

Despite we have in Zeroconfig configuration for Phone:

"Remove Manually-edited Entries on Download " : NO

manual entries in Phonebook are deleted…

What could be wrong ?

Also over web interface on IP phone I have checked and everything is configured by the book…

I tried several things but It doesn’t help…

  1. factory reset
  2. even replaced phone with brand new one
  3. latest firmware

Phone model: Grandstream GXP2135

grandgovno1

grandgovno2


#2

I have a solution. You should buy Cisco instead of Grandstream.


#3

this is a Grandstream forum, it is not the garage sale,
There is also the Cisco forum where you can propose your ideas.
Thank you


#4

are you sure its using xml and not ldap for the download? I tend to use ldap for the directory, on the phone in the contacts there is usually a download button, if you download a the new phone book it replaces the entries that the user changed locally?


#5

I am adding personal phone numbers in Grandstream IP phone, and generally ZEROCONFIG is configured that manual entryies in phonebook are not deleted on download a phonebook from UCM… but instead of this, my personal entries in phonebook are deleted… and no one knows how… I contacted my support provider who sold us Grandstream PBX and phones, and they don’t have an idea…


#6

Phone is downloading XML from UCM… but yet again configuration in a phone phonebook is as i marked with yellow color on a screenshot… and Remove manally-edited entries on Download is “NO”, so I understand It should not delete your manual edited entries… but it’s deleting…


#7

if you use Zero config it conflicts with the manual use of entering the address book, try entering the address book on zero config, instead of manually on the phone


#8

on Zeroconfig under Global Policy

XML Phonebook :

Phonebook source: LDAP Directory
Phonebook download interval: 5min
Remove Manually-edited Entries on Download: No


#9

as already mentioned, you should manage the address book either manually or via Zero Config, it’s just a suggestion.


#10

How can I manage address book via zero config, as every user have their own numbers which they save in their phones?


#11

you didn’t mention the PBX you are using,
I imagine it’s a UCM630X,
in this case I advise you to first check and then update the FW if necessary,

I honestly use LDAP configg from scratch and not XML, and I don’t have this problem

Below you will find the link to the necessary documentation, to answer all your questions,

https://documentation.grandstream.com/article-categories/ucm6300/

If you don’t receive further advice, you can contact Grandstream directly at this link
https://helpdesk.grandstream.com/


#12

Sorry, I forgot to mention, I am using UCM6302.


#13

using a 6202 and a gxp2170 with xml phonebook, the download did not remove any address i manually added to the phone. a redownload and a reboot did not delete the manually added entry.
One Caveat I found was:
the dial button on the manual added entry worked(dials number) where as the downloaded entries the dial button DOES NOT work. i will try out a 6300 later
phone config below
image