Phone key numbers wont work for menu calls


#1

Hello

Im having troubles when choosing an option from a menu when calling. or wven typing an extention

Help!


#2

It just doesnt seem to catch the key entry


#3

oh come on


#4

please elaborate the issue and your configuration.


#5

My dialing plan is this one:

{ x+ | +x+ | x+ | xxx+ }{[#x]+}

, the issue is that when i call a number that has a recording and i need to choose an option using the numbers from the phone, but the keys to choose the options wont work.

The keys work when i dial a number tho.


#6

is it every auto attendant / ivr you dial or just some ?


#7

Yes every one


#8

what sort of lines are you dialling over?


#9

im dialing a number to a bank in USA

001 800 669 4268


#11

Kev is asking what type of telephone service - SIP, analog, etc. /

You can try changing the DTMF mode to inband by going to the extension setting in the UCM, Media and DTMF mode - Inband.


#12

My type of service is SIP,

I tried changing it to inband but no .


#13

OK, change the extension back to the RFC and then change the DTMF mode on the trunk to inband and try the same.


#14

Nope, changed to inband, wont work


#15

this is very frustrating…


#16

The last thing to try is to set both the trunk and extension settings to inband and then go to the phone and do the same on the phone itself.

If that does not work, then here is what we know,

We know that the phone is able to dial out. We also know that it appears that the provider is able to interpret the DTMF by virtue of the fact that you can reach the Bank and the IVR.

To me, I think you will need to engage your provider and point out that you reach the destination and the IVR and have tried DTMF using both the RFC and inband to no avail. When you used the RFC, the provider relayed the DTMF codes. When you used inband for all 3 (extension, trunk and phone, you were using an audio channel to send the audio equivalent of the code using the keypad which is no different than what a landline phone will normally do.

You should be using a g711u/PCMU codec across all device and trunks.


#17

My codec preferences are : PCMA ; PCMU and G.729

Will reach out my provider to see if it solve it