Phone firmware won't update


#13

It always switched the HTTP to HTTPS after I reboot the phone. It won’t stay on HTTP. This is after I tried updating with the 1.0.7.97


#14

Check if ZeroConfig is not overriding your manual config.


#15

Can you please confirm that the entry for Firmware server path does not have anything before tee firmware…

Just for the moment, to eliminate other things, please turn 3CX Auto Provision to off. Then switch Upograde via back to HTTP, save and apply, and reboot.

You’ll want to turn 3CX Auto Provision back to on after this.


#16

I’m not too sure where in the Zero config it would be, but my other 2 phones updated without issues and they are both set on http.

Sorry it is size

Here is the beginning of the line too


#17

Follow these steps:

  1. Clck on No

  2. Click on HTTP

  3. Click on Save and Apply

  4. Clcik on Start


#18

My version of the firmware does not have the 4th step.


#19

Ok. Then reboot after doing the other 3.


#20

Thanks for the help. Rebooting now.


#21

I think it is working because it is taking a long time to come back on line!


#22

I think it was switching to HTTPS due to a setting in your Zero Config. Turning the 3CX option off, turns off Zero Config for the phone.

Remember to turn it back on after you finish upgrading.


#23

Um. I cannot get to the web GUI of the phone now. It has rebooted and when I go to the phone and look at the settings on the screen, the network says that it will update to the 1.0.7.97 and the http is set not the https. I rebooted from the phone’s screen and I still cannot get to the web gui. Time for a factory reset?


#24

We did not change any of the web GUI settings with what we did.

Firstly, have you tried to reset your browser window (Ctrl-F5 on Chrome)?

Secondly, has the phone’s IP address changed? Push the up arrow on the phone (navigation controls) to see what the phone’s IP address currently is.

If neither helps, then yes, do a factory reset.


#25

Ok. I can get back into the phone and it still is not updated. It is staying on the http. Is the correct path
http://firmware.grandstream.com/gxp2160/1_0_7_97
http://firmware.grandstream.com/gxp2160/1_0_7_97.zip
firmware.grandstream.com/gxp2160/1_0_7_97
firmware.grandstream.com/gxp2160/1_0_7_97.zip


#26

Try going with this one first - firmware.grandstream.com/gxp2160/1_0_9_135

If that doesn’t work then go to firmware.grandstream.com/gxp2160/1_0_7_97 first.


#27

Do I need to put that also in the place where it says config server path? Still not able to update.


#28

There is a USB port in the phone, could I load the file from it?


#29

Not that I am aware of.

Given that you cannot upload directly given your firmware version, your options are


#30

Thanks everyone for the help. Finally got the firmware changed. Now on 1.0.9.135. but now cannot get to phones web page. Weird. I think there is something wrong with this phone.


#31

I am not sure what “cannot get to the phone’s web page means”

In case it means it does not load properly, i suggest you clear your browser cache (Cntrl-F5 on Chrome).


#32

Thanks again drostoker. This phone is now UTD and working as expected :slight_smile: