Phone firmware won't update


#1

Hello everyone. I have 3 GXP2160 phones on my system and I have been able to upgrade 2 of the 3 to 1.0.9.135 firmware. One phone however isn’t upgrading. It is on 1.0.5.33. This version does not have the ability to upload a file through the web GUI like the later versions. I have rebooted the phone, changed how often it looks for new firmware, factory reset the phone, and even tried running HFS and pointing the phone to this local server to get the file (which I see it will do) but it fails to update.

Any ideas of what I can try next?

Thank you.


#2

Go to the phone’s web GUI -> Maintenance -> Upgrade and Provisioning and point the Config Upgrade via to firmware.grandstream.com/gxp21xx/1_0_9_135 using HTTP.

Then Upgrade.


#3

So i had tried this in the past and it didn’t update. I tried it again and I put in the settings, saved and applied then rebooted the phone and it is still on the old firmware.

Thanks for the suggestion.


#4

My screen will look different than your as I am on the current firmware.

Just to make sure you’re doing it all, go to the Firmware section, select HTTP, enter the URL as above (make sure to change the XX to the correct model number - in your case 60), and the click Save and Apply.

Then under Upgrade Firmware, click start - or - select Always Check for New Firmware, Save and Apply, and then reboot.

Hope this helps.


#5

Thanks again. I checked these things and made some adjustments per your recommendations. Rebooting now. One thing that I noticed is that when I go back into the phone web GUI, the internet protocol is always back on HTTPS. Rebooting now.


#6

No luck in upgrading. Could I have a bad phone?


#7

Maybe I should try it this way?


#8

Also, I think you need to upgrade to 1.0.7.x to then upgrade to 1.0.9.x. Check the firmware page on GS website for more info.


#9

I could only find firmware back to 1.0.9.32. Do you have a link to 1.0.7.x? How would I find what the X should be ?


#10

Check here : http://www.grandstream.com/support/firmware

Under High-End IP Phones, you’ll find the 1.0.8.x and “Previous firmwares” as well as upgrade notes below. This should get you up and running on latest firmware. Just pass each step.


#11

Here are the upgrading notes on the firmware page. Since you are currently on a 1.0.5.xx firmware, you shouldn’t need to upgrade to 1.0.7.97 first. That being said, there would be no harm in doing intermediate upgrades along the way - the links are below.

2. IMPORTANT UPGRADING NOTES:

- If the GXP21xx phone is on firmware 1.0.4.x or lower versions, please upgrade to 1.0.7.97 first.

The HTTP upgrading path for firmware 1.0.7.97 is:

http://firmware.grandstream.com/gxp21xx/1_0_7_97

Here are the links to download 1.0.7.97 firmware packages:

http://firmware.grandstream.com/Release_GXP2130_1.0.7.97.zip

http://firmware.grandstream.com/Release_GXP2135_1.0.7.97.zip

http://firmware.grandstream.com/Release_GXP2140_1.0.7.97.zip

http://firmware.grandstream.com/Release_GXP2160_1.0.7.97.zip

http://firmware.grandstream.com/Release_GXP2170_1.0.7.97.zip

- If the GXP21xx phone is on firmware 1.0.7.x and can’t upgrade to 1.0.9.x directly, please upgrade to 1.0.8.x first, and then upgrade to 1.0.9.x.

The HTTP upgrading path for firmware 1.0.8.56 is:

http://firmware.grandstream.com/gxp21xx/1_0_8_56

Here are the links to download 1.0.8.56 firmware packages:

http://firmware.grandstream.com/Release_GXP2130_1.0.8.56.zip

http://firmware.grandstream.com/Release_GXP2135_1.0.8.56.zip

http://firmware.grandstream.com/Release_GXP2140_1.0.8.56.zip

http://firmware.grandstream.com/Release_GXP2160_1.0.8.56.zip

http://firmware.grandstream.com/Release_GXP2170_1.0.8.56.zip


#12

Still not able to upgrade. Does this look correct?


#13

It always switched the HTTP to HTTPS after I reboot the phone. It won’t stay on HTTP. This is after I tried updating with the 1.0.7.97


#14

Check if ZeroConfig is not overriding your manual config.


#15

Can you please confirm that the entry for Firmware server path does not have anything before tee firmware…

Just for the moment, to eliminate other things, please turn 3CX Auto Provision to off. Then switch Upograde via back to HTTP, save and apply, and reboot.

You’ll want to turn 3CX Auto Provision back to on after this.


#16

I’m not too sure where in the Zero config it would be, but my other 2 phones updated without issues and they are both set on http.

Sorry it is size

Here is the beginning of the line too


#17

Follow these steps:

  1. Clck on No

  2. Click on HTTP

  3. Click on Save and Apply

  4. Clcik on Start


#18

My version of the firmware does not have the 4th step.


#19

Ok. Then reboot after doing the other 3.


#20

Thanks for the help. Rebooting now.