Paging from Fanvil phone to Grandstream GS-GXP2170 phones Failing, picking up and ending


#1

Hi guys, Using the UCM 6202.
I have two GXP2170 phones registered as Extension 21 and 22.
and 2 Fanvil X6 phones registered as Extension 23 and 24.
I set up a paging group with an extension of 10. (type - one way paging)
I added all the above extensions to the group (21-24)
I set Paging alert info header to intercom.

Then I try initializing a page using the following: *8110

It works perfectly when I initiate a page from a Grandstream phone. But fails when I try initializing a page from a Fanvil phone.

When the page fails I can see the page go through. The grandstream phones pick up the page call, but then immediately end the call.

Can anyone please shed some light on what I might be missing?

Thank you!


#2

Try placing the Grandstream phones in one page group and create another with the fanvil phones in them…

  • Test it out to see if from the Fanvil you can page to the other Fanvil.
  • Test it out to see if from the Grandstreams you can page to the other Fanvil.
  • Test it out to see if from the Grandstream you can page to the other Grandstream.
  • Test it out to see if from the Fanvils you can page to the other Grandstream.

Let us know what happens, what works and doesn’t.


#3

probably is to be revised the dial plan of the Fanvil, or probably goes in contrast with an internal code of the Fanvil.

if the problem is in reception, look at “Allow Auto Answer by Call-Info” (on Fanvil I don’t know what it’s called).
Try also *80 as well as *81


#4

Thanks scottsip,

Fanvil to Fanvil works fine. I tested that by taking the grandstream phones out of the intercom group.

Grandstream to Grandstream and Grandstream to Fanvil works fine. I tested this by adding all four to the same intercom group and initiating a page to the group. The Page gets picked up by all phones in the group and remains active until I hang up.

It’s only when initiating a page from the Fanvil to a page group that has a Grandstream phone in it that this issue arises. The page does go though. I can see the Grandstream phones picking up the call. But then the call is immediately terminated…


#5

Auto answer is enabled in call info. As I mentioned, when calls are made from the grandstream phone sthe page works correctly.


#6

Not a solution to the problem perhaps, but could you get around the symptom by using multicast paging?


#7

Did you try this on?


#8

Yes, auto answer in enabled.
*81 has the same result.


#9

you have to try *80 and not *81


#10

*80 is intercom. I’m having issues with paging.


#11

hi drostoker,
I was able to get it working using Multicast paging. thank you for that idea! Though it is a pain in the neck, as I have to configure each phone to listen to the multicast IP address individually.


#12

That’s the beauty of using a UCM and Grandstream phones, you can do it all the Zero Config! Or now with GDMS!


#13

Zero config doesn’t have multicast configuration options.


#14

so you can’t give it a try with *80? *80 is a function similar to *81, but the voice is unidirectional.

it was just to give you a tryout.


#15

It does, you just need to use PCodes.


#16

Thanks drostoker!

i did some digging and found a wealth of info on Pcodes :smile:

I found that P1569 and P1570 are the ones that need to be set to get the result that I want.

Thank you again for your help!