Outgoing route help on UCM 6102 (dialing a prefix number to select a trunk)


#1

I’ve been using my 6102 for some time with 6 trunks and 6 corresponding in/out routes.

I’m using Patterns to do 7 digit dialing and 10 digit dialing (basically if it’s 7 digits prepend my local area code and if 10 digits were used just dial as is).

This has served me well when I had the proper phones with enough sip accounts to handle all my lines.

Recenly I upgraded some phones and my phone is a GXP2130 and so it only has the 3 SIP accounts on it.

I managed to route all the incoming calls with proper ring tones and such so I can identify them without much issue but I just never used them for outgoing routes and used a softphone for the few calls I made on those trunks.

Now I’m looking to fix that.

I was hoping to just use a “dial 9” type of flag to get to the trunk I want, but it is not working.

Oh, I’m filtering by CID and 100X = outbound to trunk 1, 101X = Trunk 2 etc.

I’ve tried doing various patterns where I do _9Z. and even _9NXXNXXXXXX. and filter by CID of the extension I’m calling from and I always get “Call is rejected by the server”.

What am I missing?


#2

Hi Gilligan,

Please correct me if I understand you wrong, but you just want to be able to choose different outbound routes to use different trunks for outbound calls?

In this case a prefix for each route (like 9,8,etc) is the easiest solution.
Just make sure that you strip the prefix in the outbound route to dial the correct number.

E.g:

_9Z.
Strip: 1
In this case the UCM would call Z.

_9NXXNXXXXXX
Strip: 1
In this case the UCM would call NXXNXXXXXX

I hope this will help! :slight_smile:


#3

Correct, and that is what I’m doing… but it is not working. :frowning:


#4

And in the extension settings on the UCM, what is in this field? -


#5

It’s blank.

This extension has no problems calling out with a different trunk with the pattern of:
_Z.


#6

why not just set a privilege level?


#7

I’ve tried.

It says “call was rejected by the server”

I use the extension “trick” so that I don’t have to put dial codes in front of my other routes and I can call out on the route just depending on which extension I pick up on.

This worked great when I had a SIP line for every outgoing line so I could have an extension “group” (10XY) where X was my group. But now trying to do this with the 3 SIP account phone isn’t working so well for outgoing.


#8

your handsets have the correct privilege level?


#9

Privilege levels do not come into play when filter on source callerID is selected.


#10

You have two options (I think) -

  1. As a test, get rid of the custom routes. Instead, set the extensions needing route 1 into an extension group, do the same for route 2 and 3. This assumes that each extension in a group is unique so that extension 100 (or others) is not in more than 1 group. Then try using the group setting for each route in the:

  2. Submit a ticket.

Keep in mind that the key is the CID seen. My guess is that you are not using a custom CID as the field I asked about earlier is empty and as a result the the CID of the extension itself is used. Had you changed the CID to be John or some other number, then I suspect it would work. It used to be that the custom was not available and it presented problems for folks who wanted to use it as the system would only recognize the extension number. Again a guess, but from what I see, the group should work.


#11

I’m not sure I completely follow.

I need that extension to 99% of the time use the ATees Trunk.

Only every now and then would that same extension need to go via the Bees trunk, this is why I was hoping to do a dial 9, or 2 in this case because 2 is “Bee” on the phone. :wink:


#12

Then why are you filtering at all on CID at all?


#13

Yes, which is why I asked why are they not using privilege level instead.


#14

Because I have 3 sip accounts on this phone. They correspond to 3 different trunks.

I pick which Trunk I want to use by picking my extension.

So all 101X extensions use one trunk
all 102X extensions use another Trunk
all 103X extensions use another one.

Problem is now I need to use a 4th Trunk and I can’t grab a 4th extension. :frowning:


#15

Does it matter which extension? Just set privilege level on trunk and extension - any extension on that phone. And use that extension. Or if you wanted to restrict to your phone set a high privilege on all the extensions on that phone and the trunk.

Or just add all extensions(or yours) in the Available Ext. option (not custom dynamic route) and the rest should work.


#16

I’m not following that, sorry.

Can you explain that differently.


#17

You just want to be able to dial a ‘2’ in front to select a trunk?

The basic route setting is fine. Can you confirm that if you set a specific extension in the Available Ext. option in the trunk settings and nothing in the Custom setting that you can dial it from that specific extension?

The other option is to set a privilege level on the extensions (remove the Available and Custom options from the Trunk) - pick one (it must be the same or higher than the privilege level of the trunk. Then dial the string from that extension.


#18

This does not work.


#19

The question was, why do you need the filter at all? If you are using a pre-pended number to select a given trunk, then what is the purpose of the added filter? Just set the privilege level to say national and the make sure the Extension is also set to the same or international.


#20

You have a trailing ‘.’ at the end of your number pattern.