Outbound calls fail on FXS1


#1

I have an alarm system that’s supposed to make a phone call. It’s set to call using line FXS1. The CDR shows an icon for “Failed” and the call duration is about 12 seconds. Is there any more information?


#2

Yes,

Do you know the number that the alarm dialer is to use when calling out to the alarm company?
Did you set an outbound rule that will accommodate the number as seen from the dialer and then, if needed, re-write the number to one that your provider (not mentioned) can use to complete the call?
Is the outbound using SIP or analog?
If SIP, what codec and have you done a network capture to determine if the call is reaching the provider and if so, the results of same as seen in the messaging?
Is this a solely dedicated line, if analog, such that if the alarm is tripped, it is not competing with an analog line that might already be occupied with another call?
Is this is SIP, do you have enough call paths to insure the call can go out?

Did this ever work before? If so, what changed?
Have you tried hooking up an analog phone and dialing out to see what might happen using both the alarm company number as well as a regular voice line?


#3

I tried dialing a cell phone from a plain phone connected to FXS1. There was a dial tone but the call did not connect. There was an audio error message about not being authorized to place the call.


#4


refer


#5

Permission is set to “International”. The alarm system is not a VOIP handset. It’s trying to place a call like a regular telephone. Are there any other modifications needed for the extension?

Edit: The exact message is a female voice, “You are not allowed to dial this number.”. The busy signal then plays.


#6

I understand the alarm is not VoIP, but perhaps the outbound connection is.

It is hard to suggest any solutions as you have provided precious little information. We know the alarm dialer is not VoIP; hence why it is connected to FX1. You have the permissions set to International, but on the trunk, on the extension, or both? None of the other questions were addressed, so these remain unknown.


#7

There aren’t any cables connected to the FCO ports on the PBX.
There’s an Outbound Route with pattern “_1NXXNXXXXXX” and International Privilege Level.
The extension is listed as terminal type FXS1 and has International permission.

I’m wondering what the possible causes of not being able to dial out using a regular telephone connected to FXS1.

Does extension settings “Enable Polarity Reversal”, “Use # as SEND”, or “3-way Calling” have an effect?


#8

unless you dial an 11 digit number beginning with 1…nothing will be allowed. dial the number using1 area code and number.

You are seeking a quick answer and none of the questions you posed in your last have much to do with anything until you know what number needs to be dialed and what route it has to take using what provider.


#9

Don’t you know the arlam companys number the system calls it is a fixed number use this number for an exact match.

now you saying dial 1(2-9)(0-9)(0-9)(2-9)xxxxxx also 11 digits Iam notsur your numebr system we use either 10 or 12 not 11 unless there is a strip leading one in your config.

N = dial any n,ber 2 to9 but not a 1
X= dial any number 0-9

look at your privilages again has Ipneblett explained and look at you outbound dial plan


#10

The alarm calls a US cell phone number. It has the form 1-nnn-nnn-nnnn. The VOIP provider is Flow Route. The Outbound pattern has been working on the GrandStream handsets. The pattern is being used to set the CID on outbound calls. Dialing a regular USA number starting with (1)-(3 digit area code)-(7 digit number) works normally from the GrandStream handset. Wouldn’t it be the same for FXS1?

Calling the alarm cell phone number from a plain phone connected to FXS1 plays the message: You are not allowed to dial this number. (busy signal noise)


#11

The pattern does not set the CID, the pattern is used by the system to determine which trunk should be used, be it an analog trunk, SIP trunk or even to a peered PBX.

The pattern you provided indicates:
“1” must be the leading digit
a “2” thru “9” must be the 2nd digit (N)
any number is allowed for the 3rd & 4th digit (X)
a “2” thru “9” must be the 5th digit
any number is allowed for the 6th thru 11th digits

The FXS 1 port must also be set to International as a privilege to match the rule.

If you can dial an 11 digit number as you indicated from a SIP extension, and that extension is using the same route, then it too should have the same issue when dialing the alarm number. If the SIP extension can dial out to other numbers and the same route is used, then:

  1. The number being dialed has an issue and you should try calling the same number from your cell phone to see if that works.
  2. If your cell also cannot reach the number, then there is an issue beyond the scope of the forum to help. You will need to contact the alarm folks.
  3. If your cell can reach the number, then you need to check the pattern to see if the number meets the criteria of the pattern and correct if necessary.
  4. You can change the pattern to “1XXXXXXXXXX” which only requires that the dialing pattern be 11 digits long with the leading digit being a “1”.
  5. If you can reach the number with your cell, and all of the above fails, then contact FlowRoute as they may have a routing issue with one of their underlying carriers whose route they use to reach your destination.

#12

The solution was to set “Skip Trunk Auth” set to “Yes”.

Create Extension for FXS1
Menus -> Extensions -> Choose Extension (FXS1) -> Features tab -> Other Settings (bottom) -> Skip Trunk Auth -> set to Yes. Alternately, specifying “Dial Trunk Password” could also work.


#13

In my view that is not a solution that is now a correct setting to a poorly set up system
you did not mention that you set up pin code dialing in the first place.

Thanks