Outbound calls fail after enabling '"Send Remote Party ID"


#1

Hi all. I have a UCM6202 and I wanted to enable the ability to show the original caller ID when someone transfers a call. Eg external call comes in # 0882227777, receptionist # 1001 answers and does attended transfer to # 1002. After the transfer, phone should show # 0882227777 as the caller.

This worked when I enabled both “Trust Remote Party ID” and “Send Remote Party ID” however outbound calls stop working. If I disable “Send Remote Party ID” outbound calls work again, but I also lose the caller ID on transfer.

In the SIP trunk settings, “Keep Original CID” and “Keep Trunk CID” are disabled. I played with these settings and still doesn’t work. Also played with some of the Advanced Settings and nothing worked either.

Anyone come across this before?


#2

David, do a packet capture on an incoming, outgoing, incoming to outgoing call from the UCM it will point you to what the caller id is being sent to the outside world. Inspect the differences between those conditions that you mentioned to see what transpires.

Cheers,

Kevin


#3

Keep original CID is an indication to the system that should the call be forwarded outside the environment, the original CID will be retained. So if a call came in after-hours, for example, and was forwarded to an answering service or other and the call disconnected prior to the conversation ending; the callee would be able to return the call by looking at the history.

Keep trunk CID is a setting that when an outbound call is placed, that the CID associated to the trunk will prevail.

The two above settings are not mutually exclusive and only related to external calls. Calls coming in will to an internal destination will always retain the CID as seen in the From or Request header; whichever header is selected in the DID mode.

Kev is correct about seeing what the messaging indicates by using a capture. It could be as simple that the added info is causing the packet to become fragmented in which case the solution may be to eliminate some Codecs or extra headers. It may be something else as well, but without see the message, it’s anyone’s guess.


#4

Thanks for the replies. I did think of checking the capture in wireshark. I did a test call with and without “Send RPID” enabled and both look the same. Except for when it’s enabled the call just returns BYE.

Both captures show the ID as “admin @ xxx” (admin is written in the Caller ID field. Tried deleting this but it just re-appears.)

I’m no expert at this stuff though - what should I be looking for exactly?


#5

Could it be a setting on the phone itself? I’m not sure how Send RPID affects outgoing calls. The logs look the same but I get “number dialled is incorrect” so it must be adding something on to the number?


#6

David try the following for explanations.

You can also do Grandstream training and learn all aspects of the system and handsets no doubt. I am a user like you and have invested time and money into knowledge, you can as well.


#7

Thanks. I finally came across it in the INVITE log from UCM > Voip provider. “Unrecognised SIP Header” - RPID.

Does this mean the Voip provider doesn’t support it? Is there a way to only enable it for incoming calls? All I want is to see the original caller ID when an incoming call is transferred, but this is breaking outgoing calls :frowning:


#8

it must be enabled on both the UCM and the IP phone


#9

Yep. On the phone I enabled RPID-PAI-FROM. It works fine. Call comes in, reception transfers and the external number shows on the phone.

Problem is outgoing calls not working. It’s like the Send RPID is also appending something to the dialled phone number, and it’s returning “number dialled invalid”. In the logs everything looks fine except for the error I wrote above. After more research this seems like a normal sort of error and probably unrelated.


#10

Also there’s a 604 does not exist error. Hmm!


#11

Ok, the provider will look to a given field to determine the cid. You need to know which field that is and some may provide a portal so you can define the field they should use. Also, not all providers will allow a cid to be a number that is not on the account. Again, you will need to check with the provider. They may decline calls that show a number other than what they have associated to the account to prevent spam, fraud or other activities that may be considered questionable. Not all do, so you may be forced to find a provider that does, should yours not allow.

In any event, check the provider 1st to see where they get cid or, in what prioritizing of fields they may use, and will they allow numbers not on the account to be used as cid?


#12

Well I spoke to the provider (Internode), the guy had no idea. Useless.

I’ve tried changing the outgoing CID to the number that we register with, but that doesn’t work either. So I have no idea what their system is looking for. This sucks as I already told everyone in the office that we can now see the external number when a call is transferred, but I have to undo it else we can’t dial out.

I don’t get why the UCM hasn’t got the option to enable Send RPID just for incoming calls and not outgoing. It works fine for incoming. Maybe this could be added in next firmware update if I request it?


#13

Internode (NodePhone) offer residential style VoIP (SIP) service called NodePhone. If you have a business need, then you may need to consider the iiNet/TPG Bizphone OTT SIP service. I can help you with that if needed however call iiNet/TPG to make sure they offer RPID (CID Trust) over their lines. I have many customers on iiNet/TPG BizPhone and OTT SIP - however I am keen to offer our own SIP Services if it is business oriented.

Kevin


#14

We’ve been using Nodephone for business for years now. Haven’t had any trouble with it until this issue. It is quite minor but an annoyance just the same.


#15

If it hadn’t been an issue before this event, what has changed for it to be an issue or is it a feature that you want to use now that you had not used before on the residential service?


#16

Just a feature we want to use to obtain the original caller id when reception transfers a call. Saves us having to contact the receptionist to get the call-back number if the call drops out etc.


#17

RPID is not really an official header as it was never really adopted. It is a holdover that is still used by some, but I suspect its use will diminish over time.

RPID is sent in an INVITE. The INVITE is generated when a call is initiated, so, think about what you indicated “send RPID just for incoming calls…….”. How would you propose that the UCM send RPID on an incoming call. The call is incoming and therefor the UCM is receiving the call and is not generating the message.

You never mentioned the phone make/model and there is a setting in the phone that may have an impact -


#18

That is interesting I hadn’t seen that option. Phones are Yealink t46s and t48s. Option isn’t in UI but may be in cfg file.

After doing some googling it seems people say you still need “Send RPID” on the pbx to get the caller id to appear on Attended Transfer (even with “Refer-to Use Target Contact” setup correctly. Annoying!

Worth a try though I’ll test tomorrow.

Thanks.


#19

Nope didn’t work :frowning: Enabled the Refer-To via Yealink cfg file, but on attended transfer the internal caller ID still displays instead of the external. So it seems the only way is via the Send RPID setting and then have no outgoing calls. Great!


#20

on Yealink try:
account.1.cid_source = 6