Outbound analog routes - "you must dial 1"


#1

Hi all, I am new to GS and having an issue with a setup for my church. Have a UCM6204 I am setting up with 2 analog lines. I have created a single trunk with both fxo1 and fxo2 ports in it. Set to descend from fxo2 and then to fxo1 for outbound.

I have created a single “Outbound Dialing” route:

_8XXXXXXX
_8XXXXXXXXXX
_8XXXXXXXXXXX

This is intended for the staff to have to dial 8 to dial outside. I am then stripping 1 digit.

When I dial out to my cell phone @ 81XXXXXXXXXX, I will intermittently get a message from the PSTN stating that “you must first dial a 1 when calling this number”. However, I will immediately hang up and try the exact same dialed digits again, and the call will successfully go through. Then I can hang up and try the exact same dialed digits again, and it will say “you must first dial a 1 when calling this number”. It is very strange.

I thought maybe it was that one analog line was requiring the 1, and the other wasn’t. To test this I just switched my trunk selection to Ascend (use fxo1 first for outbound). However I experienced the exact same erratic behavior.

Can someone help guide me on this? Is my outbound route created incorrectly? What could be causing this erratic behavior?

Thank you so much,


#2

Try with 1 x line plugged in at a time and see if the fault occurs again. If it does…then it points to that telephone line or the outbound route that you configured.


#3

You can catch FXO line logs, 1 of will contain number you dialed, check what you push to PSTN.
Just search files from debug for number and see if you have 1xx or 81xx
If 81xx then you outband is wrong set.


#4

First, try an analog phone directly on each individual PSTN line if you can get the required keying in.
Then why do you put an 8 in front of the selection?
test for test to put _x. (associating the PSTN)
you should be able to dial any number.
You don’t have to create a single analog trunk with the 2 PSTNs, you can create 2 trunks (each with 1 PSTN), in the outbound paths you only address the PSTN you want and the other one you fallback.
This makes it more convenient when testing individual lines with ad hoc rules


#5

The first question is what make and model of phone? It is does not appear to be the UCM outbound rules as the call is being sent to the provider and it is the provider giving the message.
The second question is if you have more than one phone and if so, have you tested from a different one.
The 3rd question is if you set the UCM and phones for the country tone set and what DTMF method is in use (look at the extension level in the UCM). It could be that the DTMF tones are not be interpreted correctly.

My first suggestion is to eliminate the need for the leading 8 and the strip 1. For testing, there is no need to complicate matters with the 8. In the US the valid dial string lengths are 3, 7, 10 and 11 for domestic calling. The need for which to use is dictated by the provider and your calling area plans. Once the issue is sorted out, you can then add the 8 back in.


#6

I will check out the logs tonight when I am back at the system.


#7

I will try this tonight when I am back at the system. I have removed the 8/strip, as well as created two separate trunks instead of the one. I have remote access to the system but am not physically with it or able to test any dialing until tonight.


#8

3 different models of phones, have tested from all 3. GXP2135, GXP1760W, and WP820.
DTMF mode is set to RFC2833 at the extension level for the phones. Country Tone in the trunks is set to USA (thats where I am).


#9

Still occurs when doing individual lines. Tonight I am going to try an analog phone connected directly to each of the lines, without the UCM6204 connected, to verify the lines are functioning correctly.


#10

As an aside, I assume you ran the the analog line tests? If not, please refer to the manual for more details. These help to optimize the UCM for the POTS line connections as not all are equal.

You can also try using inband audio by setting both a physical phone (2135 as it should be easier) and at the extension settings for same in the UCM (try just 1 extension) as a test.


#11

Are the tests you referring to the ‘PSTN Detection’ button that is located in the Analog Trunk settings?


#12

So I tried plugging a line directly into an analog phone that I have and bypassing the system, and the dialing works correctly. I do have to put a 1 in front of local numbers as our area appears to require it, but I am not seeing the issue with this connected in this way, so I don’t believe it to be any issue with the line itself.

I do believe I have made some headway though. I added a 500ms FX0 dial delay to each of the analog trunks and they appear to be working correctly now to dial outbound, though I am monitoring closely. I am wondering if maybe the system was picking up the line, and then trying to dial too quickly before the line was ready, and it was only sometimes catching the prepended 1. I was able to dial local, long distance, and 8xx numbers for 10 calls in a row for each type and they never gave me the ‘you must dial 1 to place this call’ message.


#13

Glad you got it working and yes, sometime analog lines will need a delay before dialing.,