One way audio only when calling external number


#1

I have the UCM6202 with SIP Trunk configured and some GXP phones in LAN.
UCM is behind the Mikrotik router. Everything is working fine (internal and external calls).

Lately I configured soft-phones outside this LAN that are connecting to UCM through Internet.
Everything is OK when I’m using soft-phone to call other extensions (GXP in LAN or even other soft-phones).
The problem is when I’m trying to call any external number (through SIP Trunk) from soft-phone. I’m getting only one -way audio.

SIP and RTP ports are forwarded from router to UCM
PBX Settings - > SIP Setting -> NAT

  • external host is set (static public IP of the router)
  • Use IP address in SDP enabled
  • local network addresses configured
    NAT option for SIP Trunk is disabled
    Extensions for soft-phone has NAT enabled and Direct Media disabled.

Any ideas?


#2

I think the problem is in the trunk configuration, make sure to open the NAT in ACL if you want unpleasant surprises (just a tip)


#3

take a wireshark capture of a call… and wait for @Marcin or @lpneblett to ask you to pm them… they should be able top assist you.


#4

Hi Mr.@ero,
You have mentioned “NAT option for SIP Trunk is disabled”, please enable it and if there is still a one-way audio problem than you must check your nat configuration or Sip/RTP port support in your router. Please see the image below:

Because you are using Mikrotik router than you can ask Mr.@scottsip, he knows well about nat configuration and Sip/RTP port on the Mikrotik router.

Best Regards,
Ray


#5

Enabling NAT o SIP Trunk doesn’t change anything.

Strange thing is that after UCM reboot sometimes first connection from soft-phone to external number work OK with 2-way audio. Every next connection has only 1-way audio. I can always hear on soft-phone but on external number I hear nothing.


#6

check your rtp settings through the router - i have Mikrotiks everywhere without rtp issues


#7

Hi Mr.@ero,
Well, you can ask Mr.@scottsip about that, maybe there is something wrong with your nat configuration or SIP/RTP port configuration on your mikrotik router. It would be nice if you take a wireshark capture of call and provide the result to Mr.@scottsip or mr.@lpneblett or Mr.@Marcin so they can analyze the problem. Just for extra, maybe you can add sip provider host name into outbound proxy on your soft-phone.

Best Regards,
Ray


#8

What do you mean exactly?
On my router I forwarded UDP and TCP ports 10000-11000 from WAN IP to local IP of UCM (192.168.2.9).
RTP ports 10000-11000 are also configured under PBX Settings -> RTP Settings:

/ip firewall nat
add action=masquerade chain=srcnat comment=“defconf: masquerade” ipsec-policy=out,none out-interface-list=WAN
add action=dst-nat chain=dstnat comment=CCTV dst-address=PUBLIC_IP dst-port=8000 protocol=tcp to-addresses=192.168.2.20
add action=dst-nat chain=dstnat comment=CCTV dst-address=PUBLIC_IP dst-port=8001 protocol=tcp to-addresses=192.168.2.20
add action=dst-nat chain=dstnat dst-address=PUBLIC_IP dst-port=80 protocol=tcp to-addresses=192.168.2.11
add action=dst-nat chain=dstnat dst-address=PUBLIC_IP dst-port=444 protocol=tcp to-addresses=192.168.2.6
add action=dst-nat chain=dstnat dst-address=PUBLIC_IP dst-port=5061 protocol=tcp to-addresses=192.168.2.9
add action=dst-nat chain=dstnat dst-address=PUBLIC_IP dst-port=5060 protocol=tcp to-addresses=192.168.2.9
add action=dst-nat chain=dstnat dst-address=PUBLIC_IP dst-port=5060 protocol=udp to-addresses=192.168.2.9
add action=dst-nat chain=dstnat dst-address=PUBLIC_IP dst-port=10000-11000 protocol=tcp to-addresses=192.168.2.9
add action=dst-nat chain=dstnat dst-address=PUBLIC_IP dst-port=10000-11000 protocol=udp to-addresses=192.168.2.9


#9

No, do not enable NAT on the trunk if behind a router.

You may need to disable the SIP ALG in the router as this is enabled by default if not mistaken on Mikrotik,


#10

Hello Mr. Larry,
Thank you for your advice, Sir. You are right and I forget about that, Sir.

Best Regards,
Ray


#11

I though so. NAT on the trunk is disabled.
SIP ALG is also disabled (/ip firewall service-port disable sip)


#12

A little more explanation is needed-

  1. What is the softphone and how connected - Wi-Fi or cellular?
  2. How is the softphone itself set to handle the NAT? STUN?

Then do a network capture of a problem call so the message can be examined to see what is going on.


#13

I’ve checked many things, nothing works:
ad. 1 GS Wave and Zoiper - no difference
cellular and WiFi (different locations, operators, routers) - no difference
ad. 2 NAT - Keep and NAT- STUN (stun.ipvideotalk.com) - no difference


#14

Then do a call and capture; otherwise it is all a guess.


#15

Bad bad bad — not the correct design rethink this.


#16

I replaced soft-phone with GXP same problem.

What I’ve checked and I’m sure:

  1. communication between phones outside LAN with UCM are correct (2-way audio)
  2. there is no audio from UCM to trunk operator when calling from phones outside LAN
  3. when I do call barging of call between phone outside LAN and external number there is 2-way audio on monitor phone but external number can’t hear calling phone outside LAN

I do some network captures and noticed that there is a RTCP Goodbye packet from phone outside LAN to UCM and this ends sending audio to trunk operator. Sometimes when RTCP Goodbye is in the end of call, everything works fine.

85 is IP of my trunk operator
83 is IP of router with phone outside LAN
19.168.2.9 is IP of UCM

So the question is why RTCP Goodby is being send before end of call?

(hope I was clear enough)


#17

RTCP is not the issue.

As you can see, the RTP stream which is the audio, continues after this.
RTCP provides out-of-band statistics and control information for an RTP session and it not the reason or cause of any issues.

I have PM’ed you.


#18

It is codec issue ?
PCMA and PCMU.
Change codec settings in UCM and softphone by removing one of them on both list.

I see this more often lately.


#19

I’ve solved the problem!
PBX settings -> SIP settings -> Misc -> Early Media -> Enable Use of Final SDP - should be disabled
It was the reason of sending RTCP Goodbye, which lead to breaking audio stream.


#20

Again, RTSP is only a reporting/statistical tool. IT DID NOT CAUSE THE ISSUE.