One way audio on zero config phones


#1

Hello

Got an issue with a UCM 6202 and some phones. This is the scenario.

UCM 6202 with SIP trunk going to three phones:

Grandstream 2170
Grandstream WP820
Snom DECT M25

The Grandstreams have been configured using Zero Config.

All phones can make calls fine.

Anyone calling in can hear the voicemail box and leave a message fine.

Problem is:

When the Grandstream phones are used to answer a call, the caller can not hear any audio.

Suggestions would be appreciated.

Thanks.


#2

local or remote extensio?
Deactivated STUN on remote extensions?
Also activates keep alive


#3

Sorry, should have said.

Local extensions.


#4

Sounds like a NAT issue. Do a forum search as it will reveal much


#5

if you have a conversation between extension and extensio, is the audio two-way?


#6

Yes, between extensions, the audio is two way.


#7

then it could be different the problems, a problem of the firewall/router with SIP alg active, the firewall with incorrect NAT or with NAT not compatible with SIP, Trunk sip misconfigured on UCM etc…


#8

What I don’t understand is that all works fine with the Snom M25 - which makes me think it isn’t a NAT problem (no SIP ALG).


#9

as it says @lpneblett the forum is full of posts for that problem


#10

Snom manages NAT and other settings in one way, other vendors do not manage it in the same way.
For example, in the Office everything with Grandstream works correctly, if I activate a Snom I often have problems.


#11

But if you follow the directions I wrote on it, you should figure it out.


#12

The UCM6202 is behind a NAT, but the rules on the NAT are for a 1-1 translation (as the IP address is only used for the 6202) and no ports are blocked.

I have tried to find other threads with similar problems, but can’t. Plenty of people with NAT problems, but nothing like what I have. Are you able to give me a link to your directions?

Are you saying that the Snom may be causing the issues on the Grandstreams?


#13

I’m not telling you anything, I’m just trying to help you out.
It’s almost certainly a NAT problem, if you give the details of how you did the NAT someone can try to help you.
The more details you write the better.


#14

The issue is that you have expressed a symptom without the benefit of knowing anything of how the extensions settings are set for NAT, how the trunk is set for NAT, if you have a static or dynamic public IP, what firmware versions are in the phone and the UCM nor how the PBX settings, SIP Settings, NAT is set and if the local network has been entered into the bottom of the same SIP NAT page.

Comparing one phone to another without knowing how either is configured (one was done by ZC, the other manually) does not mean they should or will function in the same environment the same way. So, no, there is no correlation to the SNOM causing any issue whatsoever.

Each device is highly configurable to accommodate a variety of scenarios as each can be used independently of one another or with one another and with various network types.

As you might imagine, there are a bunch of folks that use ZC and GS phones on the UCM and have it all successfully working.

If I had to guess, I suspect the issue is with the SIP setting page, NAT.

Input your public static IP in the external host field.
Check the SDP box.
Input your local network into the section below.

These settings tell the UCM who is local and who is external and thus how the UCM needs to formulate its messaging.


#15

Probably what I should explain is my background…

I know (as is obvious) very little about VOIP. For five years I ran Kerio Operator without trouble. Unfortunately, as GFI no longer support this software (EOL) I decided to move to the UCM.

I have checked the SIP NAT settings, and they are already set up as suggested.

I guess I will need to play around and see where I get.

Regards

Daniel


#16

If you decide to provide some details about your setup, then perhaps some more suggestions could be offered. In the meantime, glad to see you digging around on your own. Good luck.


#17

First thing I will be doing is a complete factory reset in the event that my tinkering has caused the problem!


#18

Packets should show problem, especially if RTP is missing.
It can be PCM problem where codecs are not correctly sent.


#19

Okay, I still have had no joy in getting this sorted.

So, taking into account my limited knowledge of VOIP, this is my basic set up.

All phones and UCM 6202 using the latest firmware.

Static IP address (just used for the UCM) going to a Watchguard Firebox.

The rule on this Firebox is set as Any from all sources. IE any data coming in on a port is routed to the UCM on the same port and likewise from the UCM to the internet. Intrusion detection on the Watchguard is switched off.

I have two SIP accounts registered on the UCM (sipgate.co.uk).

Currently I have three phones registered to the UCM on three extensions.

Two of the phones are Snom (765 and M25 DECT) and the third is a GS WP820 (also have a 2170, but not using this whilst trying to troubleshoot).

All phones are fine when making outbound calls.

The Snom phones are fine when receiving inbound calls.

When the GS WP820 receives a call (and the GS2170 when it was connected before my last factory reset), the calling party cannot hear any audio. This problem only happens for calls coming in from the VOIP trunk. Internal extension - extension calls are fine.

The WP820 has been set up using the GS Zero Config option and I have also tried a manual configuration set up. Both result in the same issue.

I have tried a packet filter, but don’t have Wireshark or any reader that can open the .pcap file.

Help would be appreciated.

Thanks.


#20

exactly what ports you’ve made NAT to UCM?