No IP over DHCP


#1

Hi,

I’m new with Grandstream IP phones, I try to install round about 20 GXP1760W phones, and I get no IP address over DHCP. Only I configure the IP address manually, I get connction. I have one GXP1620 with the same issue. I work with a Linux DHCP server. on each phone I get a loop from the DHCP server with DHCPDISCOVER - DHCPOFFER - DHCPREQUEST - DHCPACK, and so on ans on. All other devices works fine. Where could be the failure?

Thanks for help
Bernd


#2

updated firmware? tried with a factory reset?
that DHCP is working properly?


#3

I made firmware update to the newest version, and some resets to factory default, it is always the same.


#4

open a ticket


#5

And in the DHCPACK, does the router send the IP, mask, DNS, etc.? Is the DHSP pool exhausted? Have you tried reserving and seeing what happens and I assume if you manually set a phone up with static info, it has no issues?


#6

yes, if I manually setup a phone with static ip there is no issue. The DHCP server send IP, mask, gateway and DNS. I have also tried to reserve the addresses but it also didn’t work


#7

Is the phone connected via a wire or wireless? I am fighting a similar / same problem.

A factory reset GXP1760W connected on a wire receives it’s IP through DHCP. It contacts the UCM zero-config and receives its config. It does a soft restart to apply the config. It acquires it’s IP again and works fine.

Disconnect the wire and reset the phone to factory again. Connect it to WiFi. It gets an IP, zero-config gives it the config, it does a soft restart, and then never acquires an IP. Multiple reboots and power cycles do not change the lack of IP.

Reset it to factory again. Use a PC to config through the web GUI to never contact zero-config. Set up the SIP accounts using the data that the UCMs zero-config says it is providing. Set up the WiFi. Apply the settings. The phone reliably acquires it’s IP and works through every reboot and power cycle.