No Inbound/Outbound Audio GXP2160/UCM6208

ip-communications

#1

I am currently working on setting up a GXP2160 for a remote site. I was able to get the unit register but I am not getting any audio inbound or outbound. When I make outbound calls, the caller ID shows up correctly. I have the ports open on the firewall. The phone in the office with the UCM have audio, it is just the phone that I am trying to setup for a remote location. I made sure that the NAT was setup and that the phone has an extension number. Like I said before, the phone is registered, just no audio for both inbound and outbound. Any help would be grateful.


#2

Here’s a quick checklist I go through when having audio issues like this:

Be sure you have forwarded ports in your firewall that accommodate the calls setup and RTP streams as well as making sure SIP ALG is off so it doesn’t rewrite packets.

Check the following:
-port forwards(this is with default settings on a Grandstream UCM)
UDP 5060 to UCM (can be locked down to just SIP Provider IPs)
UDP 10000-20000 to UCM (must be open to all)

SIP ALG must be off

On the UCM
PBX-SIP-NAT External Host should have static IP or dynamic DNS address in it (this tells the SIP Provider and external devices what address to respond to)

-Keep in mind best practice is to change the 5060 port to something else as well as narrowing down the RTP ports to a much smaller amount.


#3

I made sure that all the ports are being forward. I did change the RTP ports from 10000-20000 to a smaller range. I do have SIP ALG turned off on the router/firewall.

I do have the external static IP address in the NAT settings with the IP address setup there as well.


#4

Is 5060 open to all or is it limited?

a packet capture of the issue occurring could show a lot.


#5

It’s open to all.


#6

Do you know how to get a packet capture of call?


#7

Yes. Would you like me to send you one?


#8

Fell free to post here or send privately


#9

https://drive.google.com/file/d/105QqqW1K2YaXRe42fiFB4OHxBmeV1Pis/view?usp=sharing

Here is a link to the capture.


#10

First, the UCM is still running 1.09.68, which is so old, that there is no point in going further until it is upgraded and the settings corrected.

As it stands, the NAT is incorrect as the UCM is telling ext 112 to contact it and send the RTP streams back to the UCM local IP at its 192.168.XXX.XXX address. This needs to reflect your public IP.


#11

I can update the NAT with no issues.

As for the firmware, I am planning on upgrading it this weekend. We had an issue when trying to upgrade it last time where it removed all my Zero config files and when I tried to restore from a backup, it would not restore. I will check the NAT first to see if that will help.


#12

Read the release notes for the FW upgrade as there are specific steps required given the age of yours.


#13

I made a how to video if you need assistance.

We are available for support as well if you need it.


#14

I was able to get it working.
I miss typed something in the phone settings.