Need Help with setting up Twilio Electric Sip trunk


#1

Error on Twilio platform

Warning - 32011

Error communicating with your SIP communications infrastructure

There was a problem communicating with a specific endpoint of your SIP communications infrastructure. This means there was either a lack of timely response, an error response or an invalid response from your SIP endpoint. This may result in increased call setup times or even failed call depending on the failover configuration for your Elastic SIP Trunk or SIP application. Twilio will make multiple attempts to deliver calls to your endpoint and each failed attempt will have it’s own notification. The notification will have details about the specific error response and the SIP URI that causes the failure.

Possible Causes

  • Your SIP endpoint is not reachable due to network connectivity issue between Twilio and your system
  • Your SIP endpoint is not responding (service down or maintenance)
  • There is a firewall in your network that is blocking SIP traffic from Twilio
  • Your SIP endpoint is sending an error response, such as SIP 500 response.
  • The SIP URI specified in your Trunking Origination URI, TwiML or REST API call is invalid

Possible Solutions

  • Ensure the SIP URI used in the request is correctly configured.
  • For details on how to configure your Origination URIs for SIP trunking, please see [Origination settings]
  • For SIP interfaces verify that your SIP URI in your TwiML or REST API call, see [Receiving SIP from Twilio
  • Ensure you’ve whitelisted Twilio’s IP address ranges and ports on your firewall for SIP signalling and RTP media traffic, see IP address whitelist - Trunking or IP address whitelist - SIP Interface
  • Ensure that your SIP servers are running properly and is properly processing calls from Twilio.

UCM6104 Error
Outbound rules

Please let me know because I didn’t get a clear result from anywhere


#2


#3

The message from Twillio indicated that they were having issues in delivering calls, meaning inbound; yet you failed to mention what the problem was or if inbound, outbound or both, but showed outbound routes with no details of the NAT, Twillio setup, etc. Please provide more detail.


#4

I’m new with this so…


#5

Review the link:


#6

@mohitpat Did you get this working? I am setting up a Twilio trunk and get the same thing, but if I forward my sip ports on my firewall it will work properly. I would like to get this working with NAT but have been unsuccessful. I have other SIP trunks working just fine behind NAT but cannot figure this one out.


#7

Forwarding ports implies NAT. IT is the process of taking a data stream that was directed to your public IP of the router and then the router translates that stream into a path to the internal private IP destination to include the ports be there one to one, ranges or redirected (mapped). So, I am uncertain what the issue is because as you say, if you forward, it works.


#8

can you send me sample image please if you can i can see because i’m not tech smart like you :frowning:
and also i have static ip
Thanks for reply