Need help - how to set up GXW4008 with Skyetel SIP


#1

I’m trying to set up my GXW4008 FXS gateway to connect with my Skyetel SIP. I’ve read documentation from both and have been given a couple of hints from Skyetel support. Skyetel has some good documentation on how to configure several IP PBXs but does not have the experience / information on how to do the set up for the Grandstream device or other FXS Gateways.
Have any of you gotten this or a similar combination to work? I do reasonably well with networking but am not a telephone person so frankly some of the Grandstream configuration information is difficult for me to understand.
I appreciate any hints, good resources that I should look at, and/or advice. Thank you in advance. - Pat


#2

Normally, to use an FXS Gateway, you would need a PBX. If not, you’ll need a lot of trunks for each FXS.

What is the use-case here?


#3

We have an older PBX that only accepts POTS lines. We want to get rid of the POTS lines and use SIP instead but are not to the point where we can replace the PBX and phones. We only have 5 POTS going to the existing PBX. The GXW4008 has enough FSX ports to send each of the ported POTS lines number into the PBX. Long term the old PBX will be replaced and then I won’t need the FSX gateway.


#4

Fill:
Sip address in in Profile
Account in FXS

That should do it
Also remove not recommended codecs by Sjyline (seting same multiple times)


#5

I defaulted the gateway. On the Basic tab I put my SIP public IP, mask, gateway, and dns servers; set time zone; changed “Reply to ICMP on WAN port” to yes; and entered the Skyetel IPs in the white list for WAN side box. On the Profile 1 tab I entered Skyetel IP addresses in the primary and failover SIP server spots; removed contents from Outbound proxy; checked Use configured IP for DNS mode; and changed “SIP registration” to NO. Could not see how to remove codecs from the list so left them since PCUM is on the Skyetel list. On the FXS Port tab I put my phone number (user ID) and name in the user settings.
When I go off hook with the phone that is plugged into the gateway I get a dial tone. When I dial my cell phone from the phone plugged into the gateway it rings to a busy signal but never actually rings my cell phone. On the Skyetel dashboard the endpoint health still shows as all red (no pings getting through) but the out going calls show in the call record as 6 or 8 second calls.
What stupid thing am I missing or what did I do wrong? As a quick test I set up an IP and connected to my SIP line and it did register with Skyetel OK and did get dial tone so know that the firewall is not blocking connection to Skyetel. I did not go through to set the phone up to accept pings so still had the red on the Skyetel dashboard.
I appreciate any further thoughts. Thank you - Pat.


#6

If you can catch packets on WAN router port. It will show correct or no communication.
If not possible start syslog in HT (with sip log) and collect them. For what you describe it is hard to say without see packets. My guess - firewall block


#7

OK, always worth checking. I watched the rule count incrementing for the UDP and ping traffic rules. I did not see a lot of traffic on the codecs rule…I’ll go back and see if there is another port and/or protocol I need to open. Per Skyetel’s instructions I have no restrictions on who the audio comes in from so would hope that part is not a problem. Depending on results from that I may put a server on the WAN IP in place of the Grandstream to be able to get a better view into what is going on. Thank you for your input. - Pat