My GSWave does not give me the caller audio when with a diiferent SIP provider or regular telco


#1

My GSWave does not give me the caller audio when with a diiferent SIP provider or regular telco; but they hear me. I call them back and everything works fine.

If someone is calling with the same SIP provider, everything works fine from the instant i answer.

I am using gswave version 1.03.29 on a LG Adroid G7 one,
Any help would be appreciated,

Pierre


#2

provider registered directly on GS Wave?
tried activating/deactivating the stun?
enable deactivate keep alive?
change codec?


#3

cellular or wi-fi in addition to Damiano’s questions?

The issue is most likely related to a NAT issue. Their audio is either not making thru a firewall, or a router may have a SIP ALG in play. I am guessing wi-fi.


#4

Yes on first question,
No stun not supportef with provider,
And for codec, cant see where to change them!


#5

It never works, in multiple wifi i’ve tried, neither in cellular data.


#6

is definitely a problem with settings. Try publishing screens (covering sensitive data)


#7

Let’s be clear, who the originating carrier is, landline, SIP or other, it all still goes to your SIP provider who delivers to your WAVE. The Wave only takes messaging from and to your provider and possibly to the media server for the RTP stream that your provider told the WAVE to use.

When a call is originated and terminated all within the same provider, it is typically called an “on-network” call as they handle the messaging at each end. In some cases, the provider will respond to the IP seen in the registration and not to the contact and connection header as provided.

The WAVE has a debug function where you can record a SIP trace. I suggest you enable, make a call that exposes the problem and then disable and download and post so we can see what is apt to be causing the issue.