Must add number to white list to accept calls


#1

Just setup a SIP account to start testing calls and was getting a “All lines are busy” response to any incoming calls to the speaker. The syslog shows every number calling in as on the blacklist, but there are no entries in the blacklist currently.

16:36:47.023550199 192.168.0.125 33569 192.168.0.141 514 Syslog 154 USER.INFO: Apr 26 18:36:47 GSC3510: [00:0B:82:F9:3A:2B][1.0.0.14] PhoneCtrl::getRing: Number 6227 is on the black list\n

Adding 6227 to the whitelist allows calls to function. Is anyone else having this problem? This can’t be correct behavior.


Should whitelist be answered by default, maybe?
#2

Did you go into “BLOCKING RULES” and change “Non-whitelist calls” to ANSWER?

If this is not DEFAULT BEHAVIOUR, it should be…


#3

Yep, that was the issue. Agreed that this should not be the default behavior. I understand the usefulness of restricting calls to a paging system, and this is a nice feature that I haven’t seen in other paging systems, but not accepting calls out of the box seems odd.


#4

Yup, just spent half an hour looking at this too, haha! Should not be default unless noted somewhere, in big letters.


#5

that’s an error in the settings in the trunk sip and not in the blacklist


#6

Could you clarify? The SIP account works fine once the non-whitelist calls setting is updated. I know there are SIP level settings to verify incoming calls in various ways, and those are not causing any issues when enabled.


#7

you have to describe the exact scenario, all the deggali that can be useful if you want someone to try to help you


#8

By default all call is blocked, unless is changed by two option. option one add to white-list or accept non-whitelist.


#9

Hi,

As we mentioned in User Manual page 22-23, GSC3510 will only automatically answer the calls from whitelisted numbers.

GSC3510_User_Manual_1.0.0.7.zip (1.9 MB)

Would you guys prefer to have a function to enable/disable “Only answer the call from whitelist” instead of having this feature enable by default?

More feedback on this will be much appreciate it.

Thanks,


#10

Yes please! And disable it by default so it works out of the box!


#11

We literally spent 30 minutes on network and SIP connectivity issues when we first started testing for this specifici reason.


#12

Don’t see problem with it there, you can check number from blocked call and them to white list. Sometime it can be useful.


GSС3510 - 486 Busy Here?
#13

Yeah, but out-of-the-box, it shouldn’t block any calls.

This way, when setting up the first time, you can try it without searching why your call doesn’t work at first.


#14

Hi,

We are blocking any calls right out-of-the-box just simply because of security reason.

We will be adding a prompt on the web UI saying that “Blocking rules configuration needed to setup for the first time” or somewhere along that line.

Thanks,


#15

That’s a good compromise.


#16

For my deployments, I want to pre-configure the whitelist in the provisioning file that is loaded to each speaker. I like the way it blocks all by default right out of the box (so installers can put up the speakers right out of the box before they are configured). DHCP boot server parameters grab the config file and populate the whitelist (if I can get everything working again after testing other stuff :-).


#17

Managing a manual list via provisioning wouldn’t be ideal for us, as we would have to build out a whole new front end for this, as well as making sure to train people on updating the list any time an extension is added \ removed. That’s a lot more work in the long term to keep things working. We’ll definitely be disabling this feature via provisioning if we start deploying these.


#18

Hi,

On the latest firmware v.1.0.0.22 there will be a prompt to notify the users to set up the blacklist/whitelist before receiving any calls. This prompt will only show after factory reset / out-of-the-box and it will never show up again after you set up the Blocking rules.

Thank you,