multiple random reboots on incoming calls

bug
ip-communications

#1

I randomly run into the phone starts a reboot loop when incoming calls occur. The phone starts to ring then it reboots (grandstream logo screen and all) then the phone starts ringing again and when you try to answer it reboots again. After this occurs within 5 minutes the phone will register a missed call but when you try to check the missed call the phone locks up and reboots a couple more times.

This has happened on three occasions today and I am on the current 1.0.1.8 firmware. Two calls were internal from other extensions on my UCM6104 and the third was an incoming call to the UCM from a POTs line on one of the the UCM FXO ports.


#2

Hey Jason,

do you know if the batteries are well charged? During incoming calls there is a slight burst power consumption.

Can you please check the menu under settings->factory functions->system monitoring to see if the battery voltage is anywhere below 10% of the full charge (that would be less then 2.7V)


#3

I cannot speak to exactly where the charge was yesterday when this was happening but the phone has not been charged since these issues were occurring (no issues today)but as of right now the voltage is reading at 2.49V So that is roughly 3/4 battery showing right now.

With how outstanding the batteries have been I don’t particularly think this was a power issue as I was able to make and receive calls in between and since these issues occurred. I have purposely been running the phone through full battery cycles trying to look for potential issues as the battery is near the end of the cycle. Yesterday morning (about 4-5 hours prior to the issues ocurring) I had actually fully charged the phone as I had made it through another cycle. So within 2-3 hours prior the issues the phone had received a full charging cycle (no calls made or received during the charging until it was fully charged).

I had listed a similar issue on a previous firmware a few weeks ago that did about the same but the issues did not have multiple reboot loops like exhibited this time.


#4

Just as an update this issue is becoming worse.

Today on a fresh full charge I have had the unit reboot multiple times on incoming calls and so I have gone to the point of performing a reboot of the phone and the base with the same results so I have now even factory reset the unit and reprogrammed by hand to continue the same result. This has been the same on a UCM6102 with firmware 1.0.10.39 as well as a UCM6104 with beta firmware 1.0.10.42. Outgoing calls are still fine.

Battery fully charged
30 feet from base station
Phone shows full signal strength
unit at current 1.0.1.8 firmware


#5

Have you resolved this? My client has same problem.


#6

I have the same problem.


#7

Guys,
Please update your device to 1.0.3.22 firmware, we have improved some battery consumption for it. Please let me know if the issue still exists. Thanks!


#8

Shawn
There is small problem:
For DP750/DP720, once upgraded to 1.0.3.22 or above, downgrading to 1.0.3.17 firmware version or lower is not supported.

If this beta is not good it will be disaster.


#9

[quote=“Marcin, post:8, topic:14619”]Shawn
There is small problem:
For DP750/DP720, once upgraded to 1.0.3.22 or above, downgrading to 1.0.3.17 firmware version or lower is not supported.

If this beta is not good it will be disaster.[/quote]

Understand, but even it may not be a perfect one, it’s still our best one so far for sure. Never the less, 1.0.3.22 have our team’s 6 months effort, we improved so much on stability and user-friendly features. Also, we added handset recovery combo key in 1.0.3.22 to deal with the worst case, means 1.0.3.22 is more secure than 1.0.2.16.
We are not just releasing 1.0.3.22 to replace 1.0.3.17, every firmware has to go through all 1000+ test cases before public released. that’s why you didn’t see 1.0.3.18 - 1.0.3.21, and why we worked 5 months to release 1.0.3.17 even there are so much pushes from both inside and outside.
So please trust us, we are very serious and responsible to our every released firmware, we may still make mistake sometimes, but we are getting better. :slight_smile:


#10

I updated to 1.0.3.22 firmware. But this problem still continues. Batteries is fully charged, and after upgrade i reset s handsets.


#11

May i have the S/N of your handset?


#12

Shawn,
Thanks for explain, it was really long wait for stable beta :slight_smile:


#13

May i have the S/N of your handset?[/quote]
IPEI:
02DC2052FD
02DC204C4D
02DC204F23
02DC204DE3
02DC205388
02DC204D0C
02DC204BD4
02DC204EC9
02DC204BF8


#14

S/N is inside handset below battery :slight_smile:


#15

207GJ2RG60022A6D
207GJ2RG60022A6C


#16

Looks like something wrong with the speaker.

Could you also kindly test if the reboot can be reproduced by:

  1. changing the handset volume,
  2. off-hook by speaker,
  3. handset GUI -> Settings -> 12. Factory Functions -> Audio Loopback, see if it can pass the test.

Thanks!


#17

After the upgrade on 1.0.3.22 problem still has been resolved. I misunderstood the users. After a personal check, I can confirm that everything is OK. Thanks for the help!


#18

I had a very similar issue with a handset which rebooted when ringing. I believe it was a power issue. Battery measured 1.23V each. When I put the same batteries in a DP720 handset with a newer hardware revision (1.8A instead of 1.6A) the issue did not occur.

Both handsets were running 1.0.3.23.

So it seems to be either an issue with the older hardware revision or an actual hardware fault.

Batteries were Panasonic Eneloop Pro 900mAH minimum


#19

Hoping to revive this old thread to see whether anyone has figured it out. Client keeps complaining about random reboots in the middle of calls. This has been ongoing for a couple years, and the firmware updates still haven’t resolved (though we think it’s gotten better). I am asking the client to put aside any handset that does it, to see if we can narrow it down as specific to a hardware revision. So far, a 1.5A.


#20

reboots in the middle of calls is more like a HW issue, current FW is pretty stable that we tested it internally. Please check if your device is still under warranty, and file a ticket in our helpdesk see if someone can help you out.