MPK with unconditional call forward [*72+extension] not working with new firmware


#1

We are using grandstream phones with a UCM6510 PBX and found that after firmware upgrade to the newest firmware (phone and PBX) we cannot use MPK previously defined as speed dial to make unconditional call forward (*72 code) to a ring group or to a queue or to a IVR.

Model GXP1630: From version 1.0.4.55 to 1.0.4.152
Model GXP2170: Version 1.0.8.46 --> Version 1.0.11.3
UCM6510: firmware 1.0.19.29 --> 1.0.20.17

P.S. We first updated the phones when the error appeared. So we updated the PBX but it made no difference.
P.P.S. The unconditional call forward does work with the new firmware of UCM6510 and the previous versions of the phones firmwares, so it should be something wrong with the phone configuration (a new option that blocks it… ) or a bug in the new phone firmware.

Any help will be appreciated!
Thanks in advance


#2

I’m sorry, can I understand exactly what button you were creating, what was it for in detail?


#3

MPK = (Virtual) Multifunctional Purpose Keys
For example, GXP1630 Phones, have them at the left side oth the phone, with a red/green bulb and a white background.


#4

the MPK button for “*72” doesn’t exist for that so I’m asking for details on how you can create it, rather make me a screen that I’m interested in, it’s something I’ve been asking GS for years now but they don’t implement the BLF button for *72, so I find it strange that it worked for you, can you give me details with a screen?


#5

Using the older firmware, having configured a MPK as “Speed dial” with *72+extension it forwarded successully calls from the phone extension to the extension of your choice.
In our case the calls where forwarded to a ring group, a queue or a IVR depending of the moment. (using 3 separate buttons!)

When you pressed the desired MPK you could hear a ‘robot’ voice informing that the phone extension had succesfully enabled a call forward to the dialed extension, and indeed all future calls to the phone, were correcly fowarded to the extension.

Ex. *72100 --> forward all calls to extension 100.
This does work with firmware 1.0.4.55 and 1.0.8.46


#6

ah ok, but even if it works it is of little use because the speed dial does not interact with the led.
I thought that was weird.
The key would be useful if you could for example do “BLF *72” at that point in addition to activating/deactivating the deviation, it would also turn on the green/red led accordingly, which is what the customer wants.

Anyway speed dial with *72 … must work, you just have to figure out whether to put (for example) a pause between *72 and the number.


#7

Thanks for the suggestion.
In our case, we don’t really need the led status. After pressing a MPK button, we already know where are the calls being forwarded.

I’ve tried soft ‘,’ and hard pause ‘;’ between the *72 code and the extension) but neither of them worked. With older firmware there was no need for a pause to make it work.
Also tried the "dial “DTMF” option but it doesn’t work either.

I think the problem is that the call forward is not done to a regular extension, and done to a call group, an IVR or to a queue… would that explain the “bad” behaviour?


#8

Hello Mr.@dosi,

Have you tried to fill in the extension number or ring group number or IVR or queue in the Call Feature setting on your phone (GXP1630 & GXP2170)? Because there might be new features on both of your phones with the new firmware, which is the “forward” softkey on your phone screen. You can try it, Sir. If it works then you can replace your MPK key according to your expectations.

Good luck sir


#9

Using the new forward softwey and dialing manually the extension/IVR/… doesn’t work either.
But anyway it’s not quite what we are looking for.

This option forwards the “main” line but our phones have multiple lines, and it’s the second account that we want to forward.
When configuring MPK you select de Mode (speed dial), the account (account 2) and the value (*729405)

[we have already tested it and did’nt work] --> if we switch the main line and the 2nd line and use this new button, in this case the phone user would have to know the different IVR/group… extension code which could lead to mistake, thus every phone has its own IVR/… matches.
Switching lines would also mean that the user would have to “select” the 2nd line every time they want to call…
Thank you in advance!


#10

Well, if you want to use the forward softkey, maybe you must fill the number in the call feature setting on your phone and the forward softkey can be used for line one or line two. But if you are looking another method for your scenario then maybe you can submit a ticket or maybe you can ask someone who knows about it, Sir. Good luck Sir


#11

Dosi,
What happens if you manually enter *72XXX and then press send; forgeting about the VMPKs for the moment?


#12

Thanks for all the responses!
I think where the problem may be:
Previously it was the PBX who did the the call forward and now it’s the telepnhone who does it.
Maybe this difference explains why now it dows not work (but don’t know how to solve it)

Here is a test i did:
In previous firmware versions dialing the *72 option had an “impact” in the PBX configuration
If I log in the UCM6510 and in the menu go to --> Extensions / trunk --> Extensions --> Edit the Phone extension “i’m forwarding”–> Features tab --> Presence status “available” --> Call forward unconditional
There is the actual value of the unconditional call forward extension/group… stored

When i do the unconditional call forward using a phone with new firmware in any method (VMPKs/using the new forward key/dialing it) the setting in the PBX does NOT change.
Insted i see a “forward icon” in the phone screen.

With the old firmware, the unconditional call function worked always, even when the telephone was not connected. With the new firmware the “unconditional” call forward seems to work only when the telephone is connected. That’s why i’m saying that now this redirection is done by the phone.

Conclusion:
Is it possible to change the Call forward unconditional value in the PBX Presence status “available” setting using a MPK?
if yes… how?

Isn’t this a bug? otherwise… we should change what unconditional means :stuck_out_tongue:

Thanks in advance and sorry for the trouble!!!


#13

Look in the phone and check for enable call features:

Hover over the setting to get a description (enable local call features) of what it does -


#14

That’s it!
Thank you very much!!!


#15

What Mr. Larry said, that’s what I meant. I am sorry if my explanation is unclear and has been explained very well by Mr. Larry, thank you very much Mr. Larry (Mr.@ lpneblett)


#16

Thank you for all effords @Ray4778 !!
Sorry it’s my fault I did’nt understand what you meant.


#17

Well, the issue was that you essentially wanted a speed dial that would activate the forward function at the UCM level. It was not the soft key function, but the use of a (V)MPK.

The phone is designed such that it can work in conjunction with a variety of different PBX systems and providers that offer such features and failing these, it can do some functions on its own - lcal call features.

In any event, it is working, so all is good and I will mark the issue as solved and closed.


#18