Lost trunk registrations


I’m using firmware on UCM6102.
On 5 November all of our SIP trunks lost registration and refused to reconnect with no prior behaviour warning. All trunks were on the same provider.
I made no changes at that time, apart from setting an extension to forward unconditionally to an external number, which was done by logging in via VPN (VPN endpoint on main router, not UCM).
Each of the trunks could be connected from a softphone and there were no port blocks on the main router.
A trace showed that the initial registration was successful, but on subsequent renewals, the register request to the service provider was acknowledged with the security handshake correctly back to the UCM, but the UCM failed to send the authentication, and just responded with another register request.
A full configuration restore did not fix the problem.
However downgrading by one firmware, with a factory reset, re-upgrading and then restoration of the configuration has enabled the trunks to all register correctly again and to remain connected.

Grandstream are of the opinion that the call forward setting cannot affect the trunk registration. However I don’t have the time to delve into this at the moment, so I flag this up in case anyone else experiences a similar behaviour, with a potential fix, without actually finding out the cause.



Thanks for the post. We’ve seen a number of people with issues with the firmware on UCM61XX boxes here, so you’re likely not alone. However, I can’t say I’ve seen the specific problem you’re seeing. Glad it’s resolved for you, but I have to ask:

Did downgrading (and to what version, I assume remove any functionality or bug fixes that you had by originally upgrading to In other words, did fixing your trunk problem cause other problems?


I downgraded to, carried out a factory reset, then upgraded again, so I don’t know whether any functionality was changed or lost. I did note that the unmonitored trunks on the dashboard showed as -1 with no trunks configured, until I refreshed the page cache with F5. No other problems have shown up. Yet