Lost calls and registrations


#1

I walked down to the basement and my registration stopped. yet still connected on wifi. Had to reboot.
call came in and had no audio. dropped call and they redialed and was on about 17 minutes and lost audio again had to drop call. now it shows unregistered (extension greyed out).

needs to be a way to force a registration. Why am i losing calls and registrations?

thanks leon


#2

Most phones will re-register when you try to dial. Not sure if that will help.
The phone might drop registration due to a variety of issues - mine hasn’t seemed to be doing that - been running it for days. But if your coverage will be reduced or you are in peril of losing connection / reconnecting, that might cause you to drop registration.

Altering the registration timer might repair it faster?

The registration timer defaults to 60 minutes.

It’s possible the re-register / retry is not working as expected though?

You could test that by dropping the registration timer and see if it improves your situation?


#3

WiFi/RF is fine covers whole house and no other issues with other devices

Should not drop call while in middle of it and/or go with one-way audio. Before everyone says firewall issue not the case here I have specific rules for SIP on my Watchguard I’ve been using for years with no SIP-ALG.

I dont see a way to change the SIP registration timer from the handset :frowning:


#4

I’m not suggesting firewall :wink: one way audio caused by firewall would GENERALLY be through out the call as once the RTP stream is set up, nothing changes over the call.

no you’d have to use the webgui. I agree with you - firmware update is out though - maybe check that?
Even though you have great coverage you could have an incompatibility. I’m looking at a similar issue myself where each boot up the phone disconnects and reconnects to wifi. I’ll update firmware in a bit and see what happens there.

You could have an issue where you lose the signal though - not all wifi radios are equal - I had two notebooks - same manufacturer - same wifi card - one dropped signal constantly at one location.


#5

Hi,

My guess is there is a WiFi signal issue. If your on v1.0.0.14 just be aware it gives very inaccurate display of WiFi signal strength as mentioned in another post. You can go to Settings->About->Network statistics on the handset to check the strength when in the basement. When the call gets bad did you try moving out of the basement and see if it recovers? You can check if v1.0.0.16 fairs better in that environment, although I can tell you right now that it will warn you earlier (than v1.0.0.14) that the network signal is bad. What we are curious about is if your operating a mobile phone using WiFi and say using GSwave to make calls if it can perform better than WP800 in that same environment.

Thanks


#6

Hi there…

MY cell phone is on wifi calling and it works fine in the basement. Its a Galaxy S9. I also have other devices down here. SO I am pretty sure it’s not a signal issue. I was sitting in my chair in a meeting when this happened so it’s not like I’m walking around down here.

Using the WebGUI for everything is not fun especially if you’re nowhere near one :slight_smile:

The phone stayed unregistered all night upstairs in our bedroom where the charger is. I have not changed the registration timer yet. Had to reboot to get it to rergister. I may start a packet capture on my watchguard grabbing packets from this device.

It’s possible that you could get one-way audio during a call but it must be something else. The fact that it unregistered is the probable cause of this.


#7

I woke up and found the phone unregistered again. Unfortunately the packet capture was not running. It is running now so hopefully we will catch something later


#8

just checked and it deregistered. let me get the pcapBWW-T30-20180527-1030.zip (192.0 KB)


#9

You have Option ON. This function can de register you easy.
1 packet no reply -> disconnect. It was fixed in UCM to tolerate more missing.
If you have register account you should not use it.

There is way to much Option packets in that trace.


#10

GM Marcin…I have that set on ALL my phones. And it happened again last night but no trace. I changed retires to 10and interval to 60 seconds… but I use defaults on the other phones. Interesting.


#11

I had that triangle icon (left of bluetooth) this morning when the phone rebooted and now it is gone :frowning:


#12

the problem is with that set when it does disconnect, it NEVER reregisters and restarts again. That has to be a bug? rebooting phone is only way around this.


#13

FYI logs are going to the default server on the phone

2018-05-28 09:03:21 Allow 10.195.50.66 216.93.246.18 3478/udp 19493 3478 50-Wireless Data 0-SECV Allowed 48 63 (Outgoing-00) proc_id=“firewall” rc=“100” msg_id=“3000-0148” src_ip_nat=“70.44.10.180” geo_dst=“USA” Traffic
2018-05-28 09:03:57 Allow 10.195.50.66 216.93.246.18 3478/udp 17474 3478 50-Wireless Data 0-SECV Allowed 48 63 (Outgoing-00) proc_id=“firewall” rc=“100” msg_id=“3000-0148” src_ip_nat=“70.44.10.180” geo_dst=“USA” Traffic
2018-05-28 09:04:33 Allow 10.195.50.66 216.93.246.18 3478/udp 55598 3478 50-Wireless Data 0-SECV Allowed 48 63 (Outgoing-00) proc_id=“firewall” rc=“100” msg_id=“3000-0148” src_ip_nat=“70.44.10.180” geo_dst=“USA” Traffic
2018-05-28 09:05:38 Allow 10.195.50.66 173.254.235.84 syslog/udp 39458 514 50-Wireless Data 0-SECV Allowed 153 63 (Outgoing-00) proc_id=“firewall” rc=“100” msg_id=“3000-0148” src_ip_nat=“70.44.10.180” geo_dst=“USA” Traffic
2018-05-28 09:05:38 Allow 10.195.50.66 173.254.235.84 syslog/udp 39458 514 50-Wireless Data 0-SECV Allowed 138 63 (Outgoing-00) proc_id=“firewall” rc=“100” msg_id=“3000-0148” src_ip_nat=“70.44.10.180” geo_dst=“USA” Traffic
2018-05-28 09:06:38 Allow 10.195.50.66 173.254.235.84 syslog/udp 39458 514 50-Wireless Data 0-SECV Allowed 153 63 (Outgoing-00) proc_id=“firewall” rc=“100” msg_id=“3000-0148” src_ip_nat=“70.44.10.180” geo_dst=“USA” Traffic
2018-05-28 09:06:38 Allow 10.195.50.66 173.254.235.84 syslog/udp 39458 514 50-Wireless Data 0-SECV Allowed 138 63 (Outgoing-00) proc_id=“firewall” rc=“100” msg_id=“3000-0148” src_ip_nat=“70.44.10.180” geo_dst=“USA” Traffic
2018-05-28 09:07:39 Allow 10.195.50.66 173.254.235.84 syslog/udp 39458 514 50-Wireless Data 0-SECV Allowed 153 63 (Outgoing-00) proc_id=“firewall” rc=“100” msg_id=“3000-0148” src_ip_nat=“70.44.10.180” geo_dst=“USA” Traffic
2018-05-28 09:07:39 Allow 10.195.50.66 173.254.235.84 syslog/udp 39458 514 50-Wireless Data 0-SECV Allowed 138 63 (Outgoing-00) proc_id=“firewall” rc=“100” msg_id=“3000-0148” src_ip_nat=“70.44.10.180” geo_dst=“USA” Traffic

#14

happened again…this is a show stopper

BWW-T30-20180528-0857.zip (1.4 MB)


#15

when phone is in this state it is no longer pingable or reachable on the webgui


#16

Can be bug with option, but i also see slow response.
Also i see u use TCP -> why ?


#17

because it is another security measure I use TLS or TCP


#18

TCP have no more security then UDP.
But it need confirmation which give communication more trouble.


#19

ANyone hacking will use UDP so TCP is inherently more secure. MOst of my phones go TLS but some of them that don’t support them (older GS) I have to use TCP. Been doing this a long time.


#20

Even IF the issue is related to TCP Marcin, it should still work. FWIW we use TCP as well in a number of scenarios - TCP can help with multi-nat networks as well as reducing power draw on smart phones etc. Some networks / servers are set up that way - so it’s important in my opinion for Grandstream to work with TCP too.