Local Call Recording


#1

Hello Folks,

I’m trying to figure out local call recording on a 2170 1.0.9.135 firmware. I’ve tried a few things and, well, it kind of works.

First, I simply added a VMPK (key 9) as a record key. No other settings. This did not work.
Second, I logged into the phone directily (will use pcodes in future) and enabled local call recording and changed the dropdown to USB. This worked… Sort of.

This issue is, there is nothing on the phone that shows the call is being recorded. The manual shows the icon should start flashing but, it does not. at the end of the call, I am able to remove the USB and check on my PC and there is a file that works.

Third, after enableing local call recording, this is now a drop down that apperers along the bottom of the screen, right most button. There is an option to record here now too. I tested but, at this moment, I’m drawing a blank if that worked.

Regardless, could someone layout the proper steps to get call recording to work? Or, confirm that I’ve done what is required?

Regards,


#2

Where are the calls recording to? What storage device are you using or is it a UCM 6xxx that you are connected to?


#3

Calls are recorded to USB. Storage device is a USB. The phone is connected to a UCM but the question is about local call recording.

Call recording is turned on, and working, for all extensions except the executive group. The executive group would like a button on the phone to press to start recording should they need it. Recordings going to the USB only for privacy.


#4

That might be a problem if you have used the UCM to push the config file to the handset via zero config.

You may have to make it a manual config phone and remove the zero config so you can set it up or look for a PCode to do what you are trying to perform and push that config to the telephone.


#5

Any other input on this? @Marcin @SmartVox @lpneblett @drostoker @lstutesman

I am using a UCM but I’d like the executive staff to have direct control over individual recording and have the file saved to USB for privacy.

I’m having trouble getting local call recording to work.

Thoughts?


#6

I have a few video phones and will try local recording myself and let you know how i go.


#7

Thank you @scottsip


#8

Well first attempt with a 16Gb SD card on a GXV3240 works a treat - you just need to move the recorder application to the front screen - put your finger on the application from the app menu and drag it to the front screen. Press the recorder button and click on the Call icon to get to the recordings - play them at leisure.

I also have a USB and will give that a go and repost my findings.

Okay same again the USB recording also works without a hitch.

I see one downfall with this, you have to listen through the speaker of the phone. I havent tried with a headset.


#9

For privacy i recommend UCM record to NAS.
Then you set on NAS privilege for UCM only to write.

Then you can run script that sort recording from UCM in nas (record name have ext afair) if you want sort them by user. Pendrive is way to insecure (physical access) and not reliable (no check if usb is not damaged).

I skip phone record as it is weak way to do it.

It is random through as i have no idea what you want accomplish at end.


#10

Sorry James, but I have no experience in this area.


#11

We’ve never used the local recording function, but we can certainly start testing it for you. Who knows, we may even use it! :slight_smile:


#12

I dont have a 2170, but i have a 2130, 2140 and the gxv3240s. the 2130/2140 seem to be hit n miss with recording… the gxv3240 works a treat as needed… If someone else has a 2170, i also would like to know.


#13

We have 2140 and 2160. Was seeing if anyone was going to be in the lab tomorrow to test.


#14

Thank you all for the replies.

It’s funny how something that looked so simple on paper has caused me so much frustration.


#15

I only have a 2135 handy and while it works well, there are a few things:

  1. There is no capability for external storage capability. I have no idea of how much time might be available.
  2. When enabling the function from within the phone GUI, the softkeys RecordOn is presented in the display to start the recording and once started, the key changes to RecordOff.
  3. You have to enter the GUI and download the recordings.

It seems to work well, but I am unable to say if the external storage has other aspects that might alter things and as such, present the issues you see.


#16

To be honest I think the limitation is having to log into the telephone with the gui username and password to be able to recover the audio is far from easy.

Installer: you browse to the telephone
Executive: you what
Installer: open up firefox
Executive: okay then what google it
Installer no, you then enter the IP address into the url
Executive: the what, you are elle? no i am John

As you can see it will not be easy for Executives to use this facility. I would suggest to use the UCM and teach them to log into the UCM as their own extension number and click onto the value added area to retrieve their recordings / download or play them.

You could even make it simpler by setting a “Book Mark” and saving their username and password for them in the browser so all they do is click the book mark and then hit the log in button.

Much simpler to be honest…


#17

“Executives” at our customers tend to be smart people that run complex businesses and understand URLs. But it’s not ours to reason why someone wants to do something, just to help them do it. We’ll still experiment tomorrow.


#18

On the 2170 you can select internal or usb.

I’ve got it working to usb but, there are still problems.

The problem being, when I press record, there’s no indication that it’s recording. There’s no indication that it’s stopped recording if you press the button a second time.

However, you can just move the usb from the phone to a computer to peruse the files.


#19

Seems like its a more complicated task than to just log into the UCM and view and play the files from within a UCM, unless we are not talking about a UCM and it is something else.


#20

And thereon lies the rub. What if there is no UCM?