Issue with Grandstream 3CX Template



I hope everybody is fine.

Recently i has two situations with the provision template from 3CX.

  1. How i can change the default feature “Direct IP Call” to be disabled from the template?

  2. From 3CX, i set BLF buttons with speed dials, etc… But nothing happens. If i set this option from the IP Phone when it reboot, it lost the configuration.

I hope you can help me! :slight_smile:


Please post this on the 3CX forums as they are maintaining the templates.


  1. You need to use a custom template.
  2. Odd. Is your 3CX and phone templates up-to-date?


They told me that I had to communicate with Grandstream, because Grandstream developed the templates.

Yes, my 3cx and phone templates are up-to-date.

Probably the only way to have the feature “DIRECT IP CALL” disabled by default, it’s using a custom template. That’s one of my doubts.


In this case, BLF speed dial should work, there was an issue in the original template but they fixed it a few weeks back.

Yes, you will need to copy the official template (Settings -> Templates -> -> Copy). Then, edit this line:

<!-- # Disable Direct IP Call. 0 - No, 1 - Yes. Default is 0 -->
<!-- # Number: 0, 1 -->
<!-- # Mandatory -->

To <P1310>1</P1310>.

Once saved, go to the extension, remove the phone (copy the MAC first!) and re-add it selecting your new custom template in the dropdown list (almost at the bottom).


Thanks so much!