Issue: GDS3710 as a Wiegand Output




I am working on the GDS3710 door system. I want to use GDS3710 as a Wiegand Output. I am going to connect GDS3710 to another access control and want to use GDS 3710’s keypad only.

I followed “” for the wiring but did not get any input on d1 and d0 when I pressed keys on the keypad (tested using the multimeter). GDS3710 is not sending keypad entry to the external access control.

I can see the entry from RFID card and fob, but not from the keypad.

Note: Wiegand output is enabled on the web interface of the GDS3710.

Is there any way to program the keypad of GDS3710 just to be Weigand output?



I´ve the same.
RFID chip open the door by external Sboard (Wiegand output).
Remote Pin to Open the Door and Enable DTMF Open Door activated,
but after input *123456# the NO2 pin is active and unfortunately not the wiegand device.
B.r. Michael


Where is the door controller? GDS3710 or other device?

Are you saying GDS3710 as PIN input device and use its Weigand interface to OUTPUT to door controller to open door?
Did you enabled (by default unchecked) the Weigand setting in “Basic Setting” page and configured Alarm_Out (as output) or Alarm_In (if using as Input) accordingly with the schedule?

Since this product is launching so I am not monitoring the forum everyday now. Please open support ticket with Grandstream technical support guys. Thanks!


the door controller Sboard is indoor.
The GDS3710 is outdoor.
Door System Settings -> Basic Settings -> Wiegand Setting = Wiegand Output Enable
Wiring diagramm your sheet page 3 Wiegand Output
Door System Settings -> Basic Settings -> Enable DTMF Open Door = yes
Door System Settings -> Basic Settings -> Doorbell Mode = Both of the above
1=RFID chip activate Wiegand
2=Keypad code activate NO2
3=OpenDoor button from GXP activate NO2
All three should activate Wiegand if Wiegand Output is Enable
Thanks B.r. Michael


So the issue resolved? Please help to advise. Supposedly this should work unless it is device with bad interface board.


I am having the same issue.

When the GDS3710 reads a RFID card, I see Wiegand outputs as previous posts have stated; however, when I type into the keypad, I do not see any Wiegand output.
I have set the correct settings as advised from the previous posts but this did not work.

Does the keypad not send Wiegand Outputs at all?
Or is the keypad ONLY for the GDS3710 to activate its NO2 output (stated in installation guide for electric lock)?

The firmware that I am using on the GDS3710 is

Thank you in advance.

UPDATE: I noticed in the firmware BETA notes that this firmware “Fixed Weigand Output feature issue” and updated my GDS3710 device.
I still did not see Wiegand Outputs from the keypad unfortunately.



Yes, for current firmware and implementation, the keypad of GDS3710 is ONLY for the GDS3710 to activate its NO2 output (stated in installation guide for electric lock).

If the RFIC card is correct, then GDS verified and will send signal to connect Weigand Output device to do other operation. Are you saying you want GDS to verify the correct PIN then also sending signal to Weigand Output interface (or control device) to open door?

Please advise. Thanks!


Hi @w00t,

So I would like it if when the GDS sees a PIN (correct or not) to send the wiegand output.

I would like the other device to know when a wrong code is entered as well.

Thank you in advanced.


So you are request the GDS as output interface transparently passing the key stroke to Weigand interface? But there are tones of weigand vendors and each might use different part of the weigand protocol to do this. Due to the potential huge IOT issue, that is why we don’t implement it yet.

What protocol your weigand interface using? Could you provide some technical documents of the weigand device you are using for us to review and reference?


Our wiegand interface is using the single-key wiegand 4-bit output similar to this documentation stated on page 24.

We should be able to accommodate different Wiegand protocol formats such as in the documentation I have linked.

Thank you again for trying to get this feature figured out.


Any update on this?

I would really like to know whether Grandstream can/will implement this feature in a future firmware or not.

Thank you again for working with me on this.



Any update on this?

Still would like to know if Grandstream will be developing this or not.

Thank you in advance.


We are in exactly the same situation.
We arlready replaced a wiegand RFID reader with a GDS3710, but we would also place one in stead of a wiegand (Rosslare) keypad.


So I noticed a recent Firmware that has “Fixed Weigand Output feature issue.” in the release notes.

Unfortunately this does not refer to the keypad weigand output feature as I still did not get a weigand response from pressing a keypad number.

Still would like to know if this would be a possible feature in the future as it seems I am not the only one that is looking for this feature on this device.

Thank you in advance.



Yes, we are still working on this. This is more complexed than we original thought, a protocol re-write required. This feature make take some time to implement. Please give us some time. Thanks!



Thank you for the response and sorry for spamming this topic.

I do appreciate that you are getting this feature done for us, so thank you again and I look forward to it.


Instead of starting a new thread, figured best to post here as I haven’t found anything more current information in this search.

I appear to be having the same issues. I want to use the Wiegand output to my PDK system. If a card is valid, PDK will open the door. Doorbell is going to signal an external device, and I’m wanting to use the camera feed on my Synology NVR.

So far every aspect of this has been an uphill battle, but my primary concern is the Wiegand output to PDK. Currently PDK acknowledges that it sees a Wiegand reader but it’s not receiving any information from it.


Not familiar with PDK system. But what the firmware version of your GDS3710?

If you have the latest firmware ( , this feature already implemented based on field feedback. You need to choose and enable this feature in the “Basic Settings” webUI:

Please upgrade your GDS3710 to the latest official version (if upgrade from very old firmware, please back up your configuration and user database, factory reset and then import back the configuration and database),
then try above setting, to see whether it works in your system.

Also, make sure the the wiring of the Wiegand Interface is correct, please refer to User Manual or HOWTO document for reference.

The Wiegand Output selection will also need to be correctly selected:

Thank you for using Grandstream Access Control Products.