Intermittent inbound call issues

ip-communications

#1

Hello There,
Please can you let me know where i need to look for the below issues.
My client is having inbound issues with some inbound calls.
They have a UCM 6202 Firmware 1.0.20.23.
Codecs setting as PCMU/PCMA/G729

We reported this to the service provider and they have come back with the below:
Based on call traces we found your PBAX is sending two codecs while negotiating in 183 and 200 response back to Liquid.

Please note this could cause codec mismatch between the providers, Hence we recommend you configure PBAX to send single codec while negotiating in 183 and 200 response and share the results.

SIP/2.0 183 Session Progress

Via: SIP/2.0/UDP 192.168.246.10:5060;rport=5060;received=192.168.246.10;branch=z9hG4bKjlhmtg2090hggdemfgh0.1

Call-ID: 67cgnv8dg2gel8vt6tnc6n78a7c9lb9l@SoftX3000

From: ;tag=na7bt88n-CC-27

To: ;tag=3d9339ae-ddf9-4c85-9e72-a51ca617f351

CSeq: 1 INVITE

Server: Grandstream UCM6202V1.5A 1.0.20.23

Contact:

Allow: OPTIONS, INFO, SUBSCRIBE, NOTIFY, PUBLISH, INVITE, ACK, BYE, CANCEL, UPDATE, PRACK, MESSAGE, REGISTER, REFER

Content-Type: application/sdp

Content-Length: 251

v=0

o=- 4048324761 61773499 IN IP4 192.168.246.250

s=Asterisk

c=IN IP4 192.168.246.250

t=0 0

m=audio 17218 RTP/AVP 18 0 101

a=rtpmap:18 G729/8000

a=rtpmap:0 PCMU/8000

a=rtpmap:101 telephone-event/8000

a=fmtp:101 0-16

a=ptime:20

a=sendrecv


#2

I advise you to eliminate unnecessary codecs on UCM and on all phones, leave only PCMU or PCMA (based on your location and on what the Voip Provider accepts) and try.

p.s.: you are not in any case specifying what these problems are


#3

That is not the issue.

It is not uncommon for a device to “offer” multiple codec in an SDP message. This is done to allow the other end to determine the codec that it would like to use as neither end may know what the other wants to see upfront, so they offer and the other end selects.

However, there are certain psuedo-standards that exist such that most providers outside of North America (and a couple of other locations) will expect to see and use G711a/PCMA (same thing) and g729 as the codecs. Your use of g711u/PCMU is not typically used in your part of the world.

As others have alluded to, it is a best practice to eliminate the codecs that will not be used from the settings as there is no point in sending extraneous traffic that no one will use and it can cause the messaging to be to big and therefore it may become fragmented.

In the post, your system is telling the provider to use what appears to be the private IP of the PBX. If your provider has equipment on-site with the PBX that makes the provider appear local, then all is OK, but you either blanked out the Contact Info or it was unpopulated, but you left the “c” info (Connection header) intact. This is the IP the PBX is telling the provider to use and on port 17218.

You may need to check the settings in PBX Settings, SIP Settings, NAT and insure that the external host field is set corrrectly, SDP is checked and the local subnet in entered down further on the page.


#4

Thanks you so much for your assistance. The capture was sent from my service provider and i just copied and pasted it onto my query. I did not delete any entries.
192.168.246.250 is the PABX WAN Port and connects to the service providers Gateway on site 192.168.246.10.
I have not entered anything in my NAT settings as i have not had to do it with any of my other clients.
Would this help?


#5

It would not hurt to let the UCM know its environment. All I can say, is that I fill out the fields regardless of on-site or remote provider to include putting the local LAN segment in.

In this manner, there is no confusion of where the UCM thinks it sits and how it should respond.

Additionally, limit the codecs as well.


#6

THANK YOU so much. i will try that.