Installing manger on CentOS7


#1

Getting those errors when trying to install manager on CentOS7

[root@localhost ~]# rpm -ivh gwn*-1.0.19*.rpm
warning: gwn-1.0.19.8-1.el7.x86_64.rpm: Header V4 RSA/SHA1 Signature, key ID 60728938: NOKEY
error: Failed dependencies:
libcrypto.so.10()(64bit) is needed by gwn-mariadb-1.0.19.8-1.el7.x86_64
libcrypto.so.10(libcrypto.so.10)(64bit) is needed by gwn-mariadb-1.0.19.8-1.el7.x86_64
libcrypto.so.10(OPENSSL_1.0.2)(64bit) is needed by gwn-mariadb-1.0.19.8-1.el7.x86_64
libjemalloc.so.1()(64bit) is needed by gwn-mariadb-1.0.19.8-1.el7.x86_64
libncurses.so.5()(64bit) is needed by gwn-mariadb-1.0.19.8-1.el7.x86_64
libssl.so.10()(64bit) is needed by gwn-mariadb-1.0.19.8-1.el7.x86_64
libssl.so.10(libssl.so.10)(64bit) is needed by gwn-mariadb-1.0.19.8-1.el7.x86_64
libtinfo.so.5()(64bit) is needed by gwn-mariadb-1.0.19.8-1.el7.x86_64
libcrypto.so.10()(64bit) is needed by gwn-nginx-1.0.19.8-1.el7.x86_64
libcrypto.so.10(OPENSSL_1.0.2)(64bit) is needed by gwn-nginx-1.0.19.8-1.el7.x86_64
libcrypto.so.10(libcrypto.so.10)(64bit) is needed by gwn-nginx-1.0.19.8-1.el7.x86_64
libssl.so.10()(64bit) is needed by gwn-nginx-1.0.19.8-1.el7.x86_64
libssl.so.10(libssl.so.10)(64bit) is needed by gwn-nginx-1.0.19.8-1.el7.x86_64
libjemalloc.so.1()(64bit) is needed by gwn-redis-1.0.19.8-1.el7.x86_64
[root@localhost ~]#

What to do ?


#2

Seems el8 version is installed of the dependencies

[root@localhost ~]# yum install libjemalloc.so*
Last metadata expiration check: 0:29:37 ago on 2021-11-04T04:47:26 EDT.
Package jemalloc-5.2.1-2.el8.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!
[root@localhost ~]#

[root@localhost ~]# yum install libssl.so.10*
Last metadata expiration check: 0:32:11 ago on 2021-11-04T04:47:26 EDT.
Package compat-openssl10-1:1.0.2o-3.el8.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!
[root@localhost ~]#


#3

https://www.grandstream.com/support/resources?title=GWN%20MANAGER&hsLang=en


#4

Thought it was CentOS 7 :slight_smile:

Seems i installed CentOS 8