Incorrect time

ip-communications

#1

Our phones (mostly GXP1625/30) and PBX6108 did not update for daylight savings time. I have the PBX set to GMT-6:00 Central Time and to update from an NTP server. I updated the PBX manually since it did not update on its own. I have tried setting the global policy for the phones with and without NTP, but the phones are still on the incorrect time. I have also set the time manually at a phone (1630), but it goes back to the incorrect time when I press the home button. What am I doing wrong and how do I fix it?


#2

Try disabling both DHCP option 42 on the phone… I have observed that fixing this issue.


#3

I have both DHCP 2 and 42 disabled on the PBX and the phone. It was enabled on the phone initially, but changing it did not help.

Any other ideas?

Chris


#4

I also tried updating to the latest version of firmware and then going through the same processes I listen in the initial post, but still have the incorrect time.


#5

I have a client with 30, gxp1628 phones.

They won’t show the correct time after DST.

The 3 gxp2170 phones show the correct time.

I’ve messed around with a bunch of settings trying to get it working.

One thing that worked in a couple of the phones was to log into the phones web page and manually change the time zone to est -5 without daylight savings.

I saved and applied the setting.

Then I selected est -5 then saved and applied and the correct time showed up on the phone.

This needs to be fixed.

I have the phones all configured with zero config.

I set the time zone to -5 in both the global policy and the model policy and each individually.

Neither seemed to do anything. The time was still off by an hour.

I also did a factory reset on the phone. It didn’t fix the problem either.


#6

I have 50 1625 and it’s showing the wrong time on the display but until system info it has the right time. In the system info it has the wrong time zone. I also update to the latest firmware. The 2130 doesn’t have the issue.

One temp fix on the 1625, (doesn’t always work)
1 - reset on the time and date,
2 - then save and apply
3 - then change the time zone
4 - save and apply

that works until you reboot it goes back to the wrong time.

Any fix?


#7

When I log into the web page for any of the phones, the System Info page shows that the Sytem Time is correct. The phone still displays the incorrect time. I switched it to Eastern Time from Central on the web page. The phone still says the Time Zone is Central. This is a bug and needs to be fixed.


#8

I agree, most of the phone I have show eastern in system info but the time is correct in there but not the display


#9

The settings I got with the support that fixed my problem on GXP1625

On the Web GUI => Settings => Date and Time:
Set timezone to: Self-defined Time Zone (NOT AUTO)
Self-Defined Time Zone: MST+5MDT+4,M3.2.0,M11.1.0

I’m in Montréal (America eastern Time zone)


#10

it worked for me also for PST PDT

PST+8PDT+7,M3.2.0,M11.1.0


#11

New firmware released, has this issue been resolved in the newest firmware? (I do not see it in the changelog)


#12

Hi,

I have configured the time zone as central time as attached and don’t see a problem. This is using the default NTP server “pool.ntp.org” and disabling option 2 and option 42. Be careful when you set UCM as the NTP server and then manually configure the time on the UCM. It can throw off the reference time. It is recommended to use a public NTP server for both the UCM and GXP. This is as tested on 1.0.4.55.

Thanks


#13

I’m having the same issue on GXP1615s, just updated the firmware so I guess I’ll see if that worked.


#14

I had the same issue with the latest firmware 1.0.4.132. I set the timezone as CST and disabled DHCP 42/2 override options on the phones and still the status page would show EST but it showed the time correctly in the status page. The phones displayed an hour off.

I set the manual timezone options in the zeroconfig template for my 1628 phones and then added CST+6CDT+5,M3.2.0,M11.1.0 and rebooted my 1628’s. When they came up they had the correct time.

I used this page to get the correct settings:
http://www.grandstream.com/support/faq/common-questions/informational

This is real annoying but at least we have zeroconfig to help ease the pain!