Inbound Route with time condition does not dial external number


#1

UCM6202, Firmware 1.0.20.20
I have been unable to create an Inbound Route that has a time condition with an external number for the destination. I get the error “You are not allowed to dial this number”. If the default destination is set to the external number, it dials it just fine. I would like to have the default destination be voice mail, and have time conditions that send it to various external numbers. I have found in the How-To guide for Inbound routes a reference to the need sometimes to configure the privilege level of the inbound route, but I don’t see this option anywhere. That wouldn’t make sense anyway since I can get it to work if I don’t use Time Conditions. FYI, I tried this on Firmware 1.0.19.21 and it didn’t work. I upgraded to the latest thinking that might be the problem.

Has anyone seen this before? I uploaded a screenshot of the inbound rule.


#2

I have more info after further testing. I discovered that after getting the message “you are not allowed to dial this number”, an inbound rule under my backup trunk rules is performed. The primary and backup trunk are both with Sipstation so I have identical DID patterns. It appears that the backup trunk inbound route performs the time condition and will dial the cell phone. I then did a packet capture to confirm what was happening. The first attempt comes in on the primary trunk but is rejected by the UCM. Sipstation then routes the inbound call on the backup trunk which is accepted by the PBX and it performs the correct time rules. After all this, I went to the primary inbound route and deleted the time rule and made the default destination be the cell phone and it worked fine and didn’t reject the call from Sipstation. I must be missing something obvious here but need some help!

Steve


#3

Look at your outbound routes. Perhaps you have them set to only allow given extensions the use of same and the UCM does not have an extension by which to use.


#4

My outbound routes include both trunks and don’t have any permissions specific to extensions. Time rules seem to be the thing that triggers the issue. I route without time rules and things work fine. I did a debug log and can see the 603 Decline but can’t determine why it is done (there must be 5000 lines in the log during the 10 second phone call…). When SIPStation reroutes the declined call on the backup trunk, it works fine. I have made sure that the two inbounds are identical so I am perplexed.

Why don’t I see any permissions for the inbound routes in my options?

The How To guide for managing inbound routes says If “Default Destination” of that inbound route is selected as “By DID” or “External Number”, the call could be routed out to another external number through an outbound route on the UCM6XXX. In this case, the administrator need to configure the “Privilege Level” of that inbound route to control whether it is allowed to direct calls out to external numbers.


#5

Sent you Pm


#6

Set the privilege to internal and try.


#7

I set the Outbound to internal and it works. Will that be a security risk to leave it that way? From what I read in the guide there should be a way to give the Inbound route a permission level to use the Outbound route that has a higher permission level. Why does it need a lower permission level when using the Time Conditions but doesn’t need the lower permission if just using the default destination?


#8

The system is handing the calls not an extension and is internal. The levels are in a hierarchy. I wish they had not labeled the way they did as it can be confusing. So, think of it as:

Disable - 0
Internal - 1
Local - 2
National - 3
International - 4

The higher levels can access the lower levels. The lower levels cannot access the higher ones. So, depending on how set, it might not be a good idea to set and international dial string 011XXXXXXXX to internal as everyone, except the disabled ones, can dial it.
The key is to use the dial string in conjection with the privilege levels. As you are forwarding a number, then by definition anyone could dial it anyway. You may want to set the dial string to match the number by creating a new outbound rule so that it would be above one that might be XXXXXXXXXX or x.


#9

Any thoughts why the Inbound route dials out fine when the external number is the default but when the external number is part of the Time Conditions, I have to set the Outbound round to internal?


#10

Hmm, good point and no; nor why it does not do so on the backup trunk.
My take is that it is a bug.

The messaging showed the 603 to be normal (q.850, cause = 16). When I saw that, I thought the only thing it could possibly be was the privilege level. I had replicated it on my system as well with the same results as you. I was only focused on a single trunk.

You can submit a ticket, but it may not be addressed for a while.,