Inbound call got 404 not found


#1

Hi:

I have 3 inboud numbers, 2 toll free numbers and 1 regular number.
and both toll free numbers made into the PBX without problems.

The regular number is always return 404 not found. unable to work.
It happed to UCM6204 , then I upgrade to UCM6301, same thing happened.

Packet capture always showing “404 not found” for that regular number, but 2 toll free number just working fine.

Any body help!!!


#2

The number must match exactly to what is seen in the TO or Request SIP headers and the DID mode in the SIP Trunk setting needs to be set to tell the UCM as to which of the two fields it should use to find the desired number and format as they may or may not be the same. The below shows them being the same -
image


#5

Let me guess rule in inbound is _.
. -. means digit 0-9 not +


#6

same rules working for other 2 numbers:
+18557881888 --working
+18883556996 --working
+18328308282 not work


#7

I have tried all patterns, and also building a peer trunk for inbound, all comes back with “404 not found” for this number.
_.
_+.
_+18328308282
_18328308282


#8

Try create separate inbound for this


#9

Show the entire rule page for this number.


#10

I have tried all pattens, none of them works.
The question is , why 2 other numbers are working? the 3rd one never worked.
Happened in both 62xx and 63xx devices

Inbound routes is very simple for now. Just one line with pattern “_.”
and both toll free number working, the 3rd one failed.


#11

Place the credentials onto a softphone and see if it registers and receives calls in. Zoiper.com free version


#12

as i stated earlier _. will not work.
create new one and add _+1.


#13

Things getting even wired now.
I add another toll free number and regular number to my SIP trunk.
Guest what? Same configure, both new numbers WORKING…

but 8328308282 never worked. the other number 8329091888 just working…
Amazing…

But 8328308282 is our published number, we want it working…:frowning:

So, I am still crying for help. I will try all suggestions.
so far

  1. create all kinds of match pattterns
  2. create special dedicated sip trunk
  3. create peer trunk.
    none working…for 8328308282 …always 404 not found

#14

Also, the working inboud is not 100% working. like 80% working from logs.
20% calls got “404 not found”, 80% just working…

but for 8328308282 number, 100% failed with “404 not found”

am I doing something wrong ?


#15

My new rules pages now.

Funny things this rules works from 18329091888, which is regular number, Packet capture

Still not working for 18328308282. and packet capture


#16

20% failure rates is way too high for working one.
So, I upgrade my firmware with cloud to the latest version. Still no improvement. Why return “404 not found”? while 80% time said is ok…

Is Grandstream stable for you guys ? make me wondering… first email I had to relay with my own server. but this pattern matching thing…is that hard?


#17

Mark pjsip and channel in syslog then check, there should be reason in syslog why UCM refuse.


#18

Marcin. I almost turn on all syslog to debug mode. your hint of pjsip made the very good point.
After I went through almost 500MB of syslog files. I had some understanding how matching works.

So I add peer sip trunks back and get rid of all wild card match to prevent spam callers.

It is SOLVED now. no more 404…

Thanks a lot.