Inbound Analog Calls not ringing through to phone sets


UCM 6204, 1 analog trunk with 3 lines. Can call internally and call out fine. Incoming calls show in dashboard (port goes yellow) but no active calls showing and phones do not ring. Inbound route is fine. The only thing I can think of is that this particular site uses Telus lines with ADSL also on one line. I asked them to give me three regular two-wire analog jacks, which they did (?). The UCM works at another location fine, so it has to be something in the jack setup, I’m thinking, as we’ve exhausted about everything else.
Anyone got any ideas? Thanks…


As per Cathleen’s thread I will check to see if removing the Caller ID check helps…


Informing of us the firmware in use may help. Users are using any number of various versions and there may be issues that are associated to a version on the subject that someone may relate to.

  1. Have you tested the line viability using an old cheap analog phone?
  2. Are the FXO ports set to the country of interest along with the tones?
    3; Have you run the FXO line tests?

As you indicated that you have another UCM that is working fine, it suggests that all of the above has been done (still have to ask however) and that the firmware is the same as is the provider.

There has been an issue reported by some where when a call is received using the FXO, that the caller may hear a ring, but the call at the UCM side will not ring, or maybe ring once or partially and then either nothing or the caller is disconnected. The bottom line being that the UCM is not routing and the call is not able to be answered by a normal phone extension.

To test this, set up a IVR and direct the calls to it using a test prompt to confirm and see if the system itself will answer. If so, then you may need to make a recording of silence and then continue to let the route reach the IVR, with a timeout of 1 second with a default destination of the extension where you wanted the call to originally go. In this manner, the UCM will answer, the caller will hear nothing and then the call will be routed to it intended destination. Not glamorous, but effective.


@lpneblett the requirement to create/use a silent recording is no longer required. Grandstream has reinstated the NONE option in the IVR setup for the Prompts.

The None option is there in both the current production firmware and the new Beta. Hopefully they won’t remove it again…


Current software level (as of last week). Analog phone will work on jack. FXO Detect test do not work (show FXO Disconnect at end of test, no settings. Have tried with Inbound Route set to Extension, Ring Group, IVR, none show up in Active Calls.
Am going there shortly to see if removing the Caller ID has any effect…


I will also try dialing an IVR from an internal phone and see if that works. But at moment calls can be made internally and to outside numbers, so I think the UCM is working.
Incidentally, thanks for the advice–always appreciated!


Unchecked the “Use CallerID” box on Analog trunk and it is now accepting inbound calls! Boss says they are sure they are paying for Caller ID, so I will check it out next week to see if that is so. Thanks again to the Forum for assistance…


This just worked for me too. I have been on it all day and couldn’t get through,


Hi Vanisle,
I have the same problem, with Telus lines and the Grandstream 6208 PBX. Unchecking “Use Caller ID” works and the calls are ringing through. but the callers ID doesnt display anymore. Incoming calls show up as “Unavailable”. I have upgraded the UCM to the latest firmware. But that hasnt fixed this problem.
Not sure if you were able to get this working.


I had the same issue with Bell lines in the East coast. They said they were paying for caller ID but they weren’t getting it.

I also had another issue with a Telus customer in Edmonton and Telus said they don’t offer caller ID on PTSN lines anymore so we switched them to VoIP problem solved.

If you look at the UCM when you do an incoming call, you’ll see the Line 1 or Line 2 will flash but you don’t hear any rings. That is the caller ID function under the Analog Trunk. Enable/Disable and that will fix the problem.


You can catch PSTN signalling in UCM and see in that file if they give you number.
Alternative, just plug phone with screen and see if you have CLIP.