HT81X with Nextiva - Delay Sending Call From Queue to Agent


#1

I am using HT818, HT814, and HT812 units with Nextiva, which has a Broadsoft backend.

When an inbound call from a customer to one of our call center agents finishes, agents are placed in an Available state in the Nextiva environment so that they are eligible to receive another call immediately. However, there is a 30 second delay that occurs before agents actually receive another call.

I am looking for suggestions for settings or things to check that will help to eliminate this delay and resolve the issue.


#2

How do you actually know that the call from Nextiva is being sent at the time claimed? There is no programmatic delay in the HT other than that used to allow CID to be obtained. The only other delay that I can think of is if the person at the extension is delaying hanging up the receiver.

In most Q arrangements there is a period that can be programmed for a “wrap-up” period. It is during this time that an agent is expected to complete whatever tasks are associated to the just completed call before the next call will be sent their way, but it only impacts that same agent as the other agents are unaffected by it until they complete their own call(s).


#3

I do not actually know if Nextiva is sending the call when it looks like it should. If an agent who was not on a call signs into Nextiva and goes Available I see they get the call immediately. Also, there is no wrap up time configured for agents, so they are supposed to be Available when a call ends.

Is there anything I should check/verify when a call ends - i.e. what does an agent hear when a customer hangs up, what does the agent do when a call end?

Also, are you thinking I might implement a brief wrap-up time to see if it influences what I am seeing?


#4

Following is information provided to me regarding the call delay issue.

The ACD state falls under the Feature Sync category (Do not disturb, call forwarding, call center ACD states/login) which aren’t fully functional with Broadsoft in real time. Once your Call Center agent gets off of the phone, Broadsoft recognizes that user is no longer on the phone, updates the Status to Available but the Grandstream ATA not being able to fully sync with Broadsoft, is not recognizing this status change in real time and thus resulting in a 30 second delay before the next call is presented.

They also state that there are no settings in the Grandstream ATA that can be adjusted to influence the behavior as described above. I am taking what I’ve been told to also mean that there are no settings on the Broadsoft side that could influence the behavior.

I’m interested in any thoughts that others might have.


#5

The ATA is sent a BYE by the PBX upon disconnect or conversely generates a BYE to the PBX should the agent hang up. There is no presence setting as this is nothing more than an analog terminal adapter.

It is not clear to me as to why the ATA would need to know anything about presence. I profess not to know about the details of the Broadsoft function in this regard, but i see nothing in their documentation - https://supportcenter.broadsoft.com/modify_call_queues_my_ccount/.

You may want to ask them as to what ATAs do support the function.


#6

Usually there is setting on QUEUE which lock agent call receive after finished one. It is for user to write something in system after call (common in ticket system). In Asterisk you can set it as you want, same is broadsoft.


Enable calls to agents in wrap-up state – The wrap-up state allows agents to perform post-call work prior to receiving the next queued call. This feature only applies when the Call Center Service is active.


#7

I did change configuration to “Enable maximum ACD wrap-up timer” to 5 seconds, and to “Automatically set agent state to Wrap-up after call.” Making these changes decreases the delay to a maximum of 5 seconds before an agent receives another call. This is a substantial improvement over the the 30 seconds that was being experienced. Side effects of this, besides overall improvement - everyone is subject to the 5 second delay, even users who are not connected through ATA units that did not have any delay before. Also, users need to use a different method to place themselves in wrap-up mode if they require a longer duration wrap-up time.


#8

If you want zero talk with provider :slight_smile:
It is possible to disable it i think.

For more time, simply pause yourself ? Global are global after all :slight_smile: