HT814 Ghost Calls


#1

Hi all I am having random ghost calls on the HT814 on the FXS1 port only, the other ports(2,3) are operational but rec no incoming calls at present as line hunting from line one (the main phone number) has not been activated, therefore all incoming traffic is via line one (fxs1) at present. The three lines are connected to an analogue PABX which has call attendant activated hence incoming calls are directed to various areas of the business - the ghost calls seem to be totally random. I have run many combinations of calls in - call in and hang up while call attendant is active, call in on one line and call in on a second line etc and there does not seem to be any pattern to the ghost calls sometimes it will not happen for 4 hours then there will be 3 4 maybe 6 calls with no one there then all normal for say 2 hours. The only thing that seems to be common is that sometimes it will ring once with no audio incoming then a call will come in with a disconnect tone then it mat stop or continue for few more rings … Helppppppp


#2

I don’t have much experience with the HT814 specifically. However, using the GXP21xx phones, there are options…

Validate Incoming Messages
Check SIP User ID for Incoming INVITE
Authenticate Incoming INVITE

That I’ve set to yes.

Typically, the ghost calls are caused by port scanning. The fact that your getting ghost calls is telling me there is an underlying security issue. For example, if you put the HT814 in a DMZ, opened a port or somehow else exposed the HT814 to the whole Internet. Some things you can do to secure it.

Use a non-standard port.
setup the firewall rule to only allow access from the IP of the SIP server.

Regards,


#3

What costwise has suggested will work, Depending on the use of the device, another method is to check “Allow Incoming SIP Messages from SIP Proxy Only”/ This tells the HT to only accept messages from the IP address that you entered in the FXS SIP Server settings. This averts the added messaging involved in authenticate INVITE and covers all messaging and not just INVITES.


#4

High folks. Back onsite - I have tried settings as suggested If I set Validate Incoming Messages or
Check SIP User ID for Incoming INVITE the Ghost calls stop but so do all incoming calls - i CAN ONLY USE SETTING Authenticate Incoming INVITE set to yes for incoming calls to work.


#6

I’m having a similar issue. I just signed up for flowroute using the HT802. In their documentation they suggest forwarding traffic for the sip port 5060:

Unfortunately my ISP only gives me limited access to my ONT router firewall settings, so I can’t restrict the firewall to specific ip range. So I have left the port open as suggested above. I could set up an additional firewall but don’t want to add additional latency by adding another device.

I notice Authenticate cerver certificate domain / chain and Trusted CA certificates. If flowroute has a CA certificate I might be able to configure that to address this issue using the Authenticate invitation? It might be nice to have incoming direct IP calling if I could generate a few personal certificates and additionally use them for myself.


#7

Multiple time on this forum.
Restrict calls as @costwisewpg say do not mark others as you will block calls.
1 of this should be ok if one of them block all incoming calls.