HT813 PSTN passthrough - delay in incoming speech


Product Model: HT813
Hardware Version: V1.1A Part Number — 9610006311A
Software Version: Program – Bootloader – Core – Base –

I want to make most of my calls via the FXO line and have {L:x+} in the FXS Dial Plan (simple configuration just for testing purposes at the moment). My problem is that there is a long delay before I hear the result of the dialled call. For example if I dial 1471 (in the UK) for the last number called, the actual message begins “Telephone Number 012345678901 called today at….”, but the delay lasts until part way through the actual number. Using the standard short code of *00 works as expected and the recorded message is received from the start. The SIP side of things is working fine, although I have not defined any account in the FXO tab, it is not enabled.

Can anyone advise if there are any of the settings in the configuration that could fix this?

Thanks … Andy.


When you dial a message, use the “#” to send immediately.

If this not done, then the HT is waiting to see if there is any additional input as it does not know how many digits to expect. It will wait for 4 seconds (default) and if no user input in that time, then it will dial.


Thanks for the reply. Yes I tried that, but it makes no difference. The call appears to be dialled ok, it is the first 5 or so seconds of the inbound audio that is missing. For example, if I call my mobile, it is already ringing before I hear the ring tone on the FXS connected phone.


What is connected to the FXS side? How are calls initiated? In other words, when you use the *00 code, you are in pass thru as you are telling the device that you want the FXS port to be joined to the FXO whereupon you are presented with a dial tone and can dial out as you please.

When you dial the 1471 number, I assume the FXS side is configured for a SIP server which then routes back out, but the following has me confused if such is the case.

In the one statement you indicate you want to make most of my calls via the FXO line; yet in a later statement you indicate that you have not defined anything in the FXO Tab. If nothing is configured, then it is not clear to me how the 1471 dial string is seen by the FXO at all, so I must be missing something.


Sorry to confuse.

I have a regular touchtone telephone connected to the FXS port and I have configured my SIP account on the FXS tab of the GUI. Calls can be made and received via SIP ok. On the FXO tab I haven’t configured a SIP account as I didn’t think that was necessary for what I intended to use the HT813 for. I have configured the FXO Termination parameters though. The Dial Plan is configured in the FXS port settings.

Do I need to setup the SIP account on the FXO tab also?


Just to further illustrate this issue, when I dial the 1471 number followed by # the FXO indicator on the adapter illuminates immediately. At this point when I pickup the receiver of a second phone on the PSTN line I can hear the recorded message from the start. The FXS phone joins in after a few seconds at the same point in the message I am listening to on the second phone. So the message appears to be truncated traversing from FXO to FXS.


If the FXS account is setup and registered as an extension, then an outbound call is managed by the SIP server. To get to the FXO for the outbound the server would have to direct the call to the ATA.

*00 allows the FXS port to connect to the FXO port directly whereupon you are provided with the line dial tone and can dial out.

I suspect that if you remove the PSTN line from the FXO port and then dial 1471 from the FXS phone, the call would still flow, but out the SIP server side. Try this and let us know what happens.


I have removed the PSTN line connection, but this results in a busy signal on both the *00 path and the dial plan path. I think my previous post illustrates that the FXO port is actually being used for these calls, but for some reason the start of the message is lost. I need to discover a solution for that.


The busy on the *00 is understandable.

What I am trying to determine is how the call gets to the FXO. The pass thru is only a function of the *00.What is the SIP server to which the FXS is registered, a PBX provider, etc.?.


I am using the Route to PSTN feature.

Quote from the User Guide.

Route Calls TO PSTN

The FXO port enables access to the PSTN network. By default, the HT813 is in VoIP mode at off-hook. If “Route Call to PSTN” is configured, certain calls will be initiated from the FXO PSTN line port. This call feature is especially useful for emergency calls or local telephone calls.

To use this feature, users need to specify a special rule using the dial plan parameter located under FXS Port configuration page. If the dialed digits match the specified prefix, outbound calls will be initiated from the PSTN line.

Note: The route to PSTN feature is only applicable to a phone connected to the FXS Port. The configuration is done using the “dial plan” feature under the FXS tab. An example of the configuration is {L: 911x+}. This shows that only calls that start with 911 are immediately forwarded to the PSTN line. All other numbers will not be routed to the PSTN. A normal # would be: {L: 617x+|x+} or {x+| L: 617x+}

For example, if “Route Call to PSTN” is configured as {L: 626x+}, all outgoing calls starting with 626 will be initiated from the PSTN line.


Well, good to know. I have one and will set it up to see the results.


That will be interesting … thanks for your help.



OK, back in the office and set it:

Same firmware.
Same dial plan on FXS port
FXS port registered to a PBX
FXO port not registered and registered
Using Viking POTS line simulator
Only difference should be the line condition between US and UK.

Dialed number, takes about 5 seconds to ring other end. Upon answer at ringing end, audio was immediately available. There was never any lag or delay.

This is what I thought it would do as I imagine that similar to the *00, the Lx+ simply interconnects the FXS and FXO together at the completion of the dial string input. In looking at the LED indicators, the FXS is on with Blue indicating that it is registered, The FXO is off or blue depending on its registration state. When I dial and connect, both FXS and FXO LEDs are blinking. The status page shows both lines to be in use. If I pull the POTS line, the simulator sends a congestion tone and the HT disconnects and returns the FXS to on-hook and the FXO to idle.

In short, I never had an issue with the audio not being present and I made a number of calls.

Have you tried simply dialing a different number where you can speak to someone?



Many thanks for taking the time to conduct that testing for me, much appreciated.

You are correct, I have never actually made a call that was answered by a human, :slight_smile: so have tried just now to my mobile and to my VoIP line through another ATA. In both cases the telephone rang, but no ringing tone was immediately audible at the FXS. However, when answered the “Hello” was indeed audible. So it looks like whatever “channel" the ring tone or recorded announcement is received on is not being relayed immediately or recognised. Strange! I wonder if there is a Tone setting that is incorrect?

I’ve a ticket open with Grandstream, so I’ll update with this additional information.

Thanks again for your help.



My rings were fine. However…good luck.


I’ll need it!


Did you ever get anywhere with this?
I’ve just posted this which looks to be exactly the same issue but with some debug logs.


In a word - no, I sent the unit back. Grandstream support were useless and could not understand what the issue was, they simply repeated I try things I’d already told them I’d done.


Oh joy… What did you end up replacing it with ? I may end up returning mine then if I can’t get any further. See my other thread for details.


To be honest I can’t actually remember exactly what I was trying to achieve, such is the passage of time and my seemingly ever-changing configuration. Currently I’m using a Gigaset N300A for the cordless handsets which neatly combines PSTN and VoIP and a OBiTalk OBi202 in front of my PABX, but the OBi202 doesn’t do POTS. These ATA devices are quite hard to come by these days.