HT813 FXO unable to detect incoming CALL


#1

Hi,

My HT813 gateway seems unable to detect incoming call from PSTN via FXO.
Outgoing calls work perfectly from SIP to PSTN.
Just after reboot, i can get the caller Id for the first incoming call, but not for next calls.

On my syslog server i get these informations :
GS [00:0B:82:E1:5C:05] [1.0.1.2] LIBGSDSP: CSS: 102527871, p_ue_CID_Progress:271 Unmute TX line for UT_FXO ev 1001#012
(null) 1538086905.983137 GSDSP::event_handler_chan, EVENT_CID_DETECTED on port 1#012
(null) 1538086905.988536 GSDSP::stopCIDDetection on port 1#012
(null) 1538086905.989312 Nuvoton::decodeCidNumber, MDMF Format CID Caller Number 06xxxxxxxx#012
(null) 1538086905.990814 EventManager::run: Dispatching event 41 (FXO_CID_RECEIVED) on port 1:0#012
(null) 1538086905.991051 SigCtrl::processFxoCallerIdReceived, number = 06xxxxxxxx#012
(null) 1538086905.991179 SigCtrl::processFxoCallerIdReceived, Update FXO CID is disabled#012
(null) 1538086906.211764 ATACtrl::processFxoCallerIdReceived on port 1:0, status = CALL_IDLE/CALL_IDLE#012
(null) 1538086906.212752 ATACtrl::processFxoCallerIdReceived, cidInfo[1].callerName = #012
(null) 1538086906.213912 ATACtrl::processFxoCallerIdReceived, cidInfo[1].callerNumber = 06xxxxxxxx#012
(null) 1538086907.838907 Nuvoton::run(), FXO_POLARITY (1) event received on port 1 ch 0#012
(null) 1538086907.839923 EventManager::run: Dispatching event 34 (LINE_POLARITY_CHANGED) on port 1:0#012
(null) 1538086908.758538 Nuvoton::run(), IFX_TAPI_EVENT_FXO_APOH event received on port 1 ch 0, status =CALL_IDLE#012
(null) 1538086908.758800 Nuvoton::run(), IFX_TAPI_EVENT_FXO_APOH event Ignored on port 1 ch 0#012
(null) 1538086908.898720 Nuvoton::run(), FXO_POLARITY (65535) event received on port 1 ch 0#012
(null) 1538086908.899937 EventManager::run: Dispatching event 34 (LINE_POLARITY_CHANGED) on port 1:0#012
(null) 1538086909.898640 Nuvoton::run(), IFX_TAPI_EVENT_FXO_NOPOH event received on port 1 ch 0#012
(null) 1538086912.858859 Nuvoton::run(), FXO_POLARITY (1) event received on port 1 ch 0#012
(null) 1538086912.859918 EventManager::run: Dispatching event 34 (LINE_POLARITY_CHANGED) on port 1:0#012
(null) 1538086914.238506 Nuvoton::run(), IFX_TAPI_EVENT_FXO_APOH event received on port 1 ch 0, status =CALL_IDLE#012
(null) 1538086914.238767 Nuvoton::run(), IFX_TAPI_EVENT_FXO_APOH event Ignored on port 1 ch 0#012
(null) 1538086915.098663 Nuvoton::run(), FXO_POLARITY (65535) event received on port 1 ch 0#012
(null) 1538086915.100199 EventManager::run: Dispatching event 34 (LINE_POLARITY_CHANGED) on port 1:0#012
(null) 1538086915.101622 Nuvoton::run(), IFX_TAPI_EVENT_FXO_NOPOH event received on port 1 ch 0#012
(null) 1538086917.878649 Nuvoton::run(), FXO_POLARITY (1) event received on port 1 ch 0#012
(null) 1538086917.879982 EventManager::run: Dispatching event 34 (LINE_POLARITY_CHANGED) on port 1:0#012
(null) 1538086919.378548 Nuvoton::run(), FXO_POLARITY (65535) event received on port 1 ch 0#012
(null) 1538086919.379991 EventManager::run: Dispatching event 34 (LINE_POLARITY_CHANGED) on port 1:0#012
(null) 1538086922.958615 Nuvoton::run(), FXO_POLARITY (1) event received on port 1 ch 0#012
(null) 1538086922.960014 EventManager::run: Dispatching event 34 (LINE_POLARITY_CHANGED) on port 1:0#012

My HT813 show port status : FXO Idle xxxx Registred
Basic configuration is :

  • WAN only
  • Unconditional Call Forward to PSTN : 0xxxxxxxxx (My number)
  • Unconditional Call Forward to VOIP: 1002@192.168.3.248:5060

Advanced settings :

  • System Ring Cadence: c=1650/3350;
  • Dial Tone: f1=440@-12,c=0/0;
  • Ringback Tone: f1=440@-20,c=1650/3350;
  • Busy Tone: f1=440@-20,c=500/500;
  • Reorder Tone: f1=480@-21,f2=620@-21,c=250/250;
  • Confirmation Tone: f1=350@-11,f2=440@-11,c=100/100-100/100-100/100;
  • Call Waiting Tone: f1=440@-13,c=300/10000;
  • Prompt Tone: f1=440@-12,c=0/0;

FXO settings :

  • Account Active: Yes
  • Primary server: 192.168.3.5
  • SIP User ID: **********
  • Authenticate ID: **********
  • SIP Registration: Yes
  • Caller ID Scheme: ETSI-FSK During Ringing
    FXO Termination :
  • Enable Current Disconnect : No
  • Enable PSTN Disconnect Tone Detection : Yes
  • PSTN Disconnect Tone: f1=440@-40,c=500/500;
  • Enable Polarity Reversal : Yes
  • AC Termination Model : Country-based
  • Country-based : France
  • Number of Rings: 1
  • PSTN Ring Thru FXS: No

Firmware version used : 1.0.1.2

I’ve tried differents settings, but i always get the same CALL_IDLE result.

Thanks for your help.


#2

so after restarting it only works once? activated keep alive at 15 seconds? activated and set the stun?


#3

In fact, I only get CID in log, then a lots of “LINE_POLARITY_CHANGED”.
It’s as if the PSTN line was working, but the ring was not detected.


#4

Hello Christophe, something new ?


#5

Hi Christophe,
You are not alone to have problems with the HT813 FXO port. However, if you live in France as shown in your profile, the system ring and ringback tone cadence should be set to 1500/3500 ms in the ATA parameters (advanced settings). This may be critical for the FXO port to detect an incoming call.


#6

Hi,

I changed my settings for cadence to 1500/3500, but still no detection.
I think the ring is not detected because my gateway is behind a DSL BOX, not on a real PSTN line.
I found someone who used an oscilloscope to compare the ringing tone on a PSTN line to the simulated one, behind a DSL box like mine.
Real%20PSTN
Behind%20DSL%20BOX

I have opened a support ticket to get help with this.


#7

in the incoming clip recognition try to set it to “auto”


#8

Freebox Revolution ?


#9

Yes, it’s a Freebox Revolution


#10

It seems that the previous model (HT503) works behind a Freebox:

Il semble que le modèle précédent (HT503) fonctionne derrière une Freebox :


#11

I had understood that it was not a “real” analogue, did you have the proof I told you?


#12

I do not have incoming clip recognition parameter