HT813 FXO not sending INVITE


I am trying to build an answering machine with Asterisk 18 and a HT813. When an incoming call to the FXO (from the PSTN) arrives, not SIP/INVITE is issued. The HT813 shows FXO as registered. The syslog shows
the caller id information correctly, but I never see an INVITE from the HT813. (I checked with wireshark as well.)
After the “number of rings”, the HT813 just hangs up.
At what point should the HT813 send the INVITE? Were should I see it in the syslog?
HT813 firmware 1.0.15. Using the WAN port only.


what do you see on asterisk cli when the external call rings in via the fxo?


Did you make sure to set the unconditional forward to voip
And disabled the ring thru fxs port?


similar to the following:


I see nothing on the asterisk cli (except the REGISTER transactions).
I have disabled the ring thru fxs port.
OK, I’ll try “unconditional forward to voip” setting.
Should the UserID be the same as my FXO SipUserID?
And the port be the same as my FXO LocalSipPort or should it stay 5060?


Follow the documentation in the link and mirror what the UCM settings are and it should work correctly.


Setting “unconditional forward to voip” was the key to getting the HT813 to send INVITE. (This probably should be moved from the Basic Settings to the FXO Termination settings, or at least documented there.)
From what I gather, the “sip destination port” in “unconditional forward to voip” should be the same as the FXO “local SIP port”. The documentation that was reference has both as 5060, but my asterisk pjsip configuration already used that for something else.

Now INVITEs are being send to asterisk, but being denied with “no matching endpoint”. I must assume that’s
my problem with asterisk configuration.


I would guess it is your config problem for sure, ergo to follow the guide.


This is curious, the INVITEs sent to asterisk:

<— Received SIP request (1430 bytes) from UDP: —>
INVITE sip:telco@ SIP/2.0
Via: SIP/2.0/UDP;branch=z9hG4bK1426306498;rport

Has the port 5060 in the INVITE even though I set the “sip destination port” to 5066.
Could it be that the HT813 is hardwired to always send the INVITE to port 5060?
And that’s why the documentation uses that port?


What does the Asterisk CLI say when there is a call coming in?


Double confirm if the port is set under the unconditional fwd or under fxo account settings.

Check the ht syslog to make sure that the port is not changed by network devices


show me trunk setting?

I had a problem with this for example ***Use P-Preferred-Identity Header:***. Use Privacy Header:


Why is the HT set to use the WAN IP? If on the same network as FPBX, it should use the LAN IP.


LAN on HT813 is dhcp.server
I use WAN, ICMP enabled, web acces, ssh, telnet too

if you want to use it differently, use it


image image image


the author just has a trunk and its adapter not configured correctly, everything works fine for me
except for one [macro-dialout-trunk]
exten => s,n,ExecIf($[$["${DB(AMPUSER/${AMPUSER}/cidname)}" != “”] & $["${CALLERID(name)}"!=“hidden”]]?Set(CONNECTEDLINE(name,i)=CID:${CALLERID(number)}))
exten => s,n,ExecIf($[$["${DB(AMPUSER/${AMPUSER}/cidname)}" != “”] & $["${CALLERID(name)}"=“hidden”]]?Set(CONNECTEDLINE(name,i)=CID:(Hidden)${CALLERID(number)}))

to automatically call an Outbound route, the prefix “CID:” is added automatically
And I do not know how to fix itimage


will you be able to provide packet capture?


I don’t remember but somewhere there is a LAN/WAN parameter, make sure it is set to WAN (or LAN), and see if it solves it -> always restart the HT813


lol, the author of the post is right, now modulated incoming and outgoing calls.

The invite did not return when I dialed a call to the operator’s number, the mobile phone answered the incoming call, but the Adapter did not invite and did not connect to the PSTN


it is a pity that the author of the post did not share his logs and logs


in summary, have you solved it? As?


To be clear, I indicated that if the ATA and FPBX are on the same LAN, then you should use the LAN IP setting. I did not indicate to use the LAN IP or WAN IP regardless, but rather the LAN IP under the one condition I presented. If that condition was/is not present, then the use of the WAN may be appropriate and if the WAN public IP is static, then you should also populate the NAT IP with such as well.