HT813 does not update the firmware

bug

#1

Product Model: HT813
Hardware Version: V1.1A
Part Number: 9610006311A
Software Version: Program: 1.0.0.1
Bootloader: 1.0.0.1
Core: 1.0.0.1
Base: 1.0.0.1
CPE: 1.0.1.79

The device can not update the firmware.
How updated?
Upgrading via Local Directory

  1. Download the firmware file from Grandstream web site
  2. Unlock Your PC
  3. From the HT813 web interface (Advanced Settings page) you can browse your hard drive and
    select the folder you previously saved the file (HT813fw.bin)
  4. Click “Upload Firmware” and wait for the new program is loaded.
    The device downloads the file and becomes unavailable. Access can be returned only by rebooting the device.
    Who faced this problem or someone can confirm the problem!
    Tried the following software …
    Firmware Version 1.0.1.2
    Firmware Version 1.0.0.8

Thank!


#2

It does take a few minutes after the download for the device to then update internally after which point it reboots.

You could also simply input the grandstream URL and then reboot the device and let it go and get same from the GS site. This assumes connected to your network and has gateway to Internet. Might be easier.


#3

as he says @lpneblett try to manually enter the following link “firmware.grandstream.com” in HTTP and restart HT813, obviously it must be connected to the internet and you have to set up automatic update.
Restart and go for a coffee


#4

Guys, Another time I tried to update locally, and it turned out (v.1.0.1.2)! Still, is there a method to restore the firmware if the update is not successful? Please tell me? Thank you very much!


#5

I am not sure I understand the question. 1.0.1.2 is the latest firmware for the device which I assume has solved the initial problem of not being able to update previously…

If you are asking about reverting to an earlier version F/W, the answer will be found in the release notes, which should always be reviewed when contemplating a change. In some cases the firmware alters how the device resources are allocated and trying to revert may not be possible.


#6

I mean.
Is there a firmware method (for example, GXP terminals) if the update procedure is not completed correctly or abnormally? And the device does not work.


#7

normally the product if it fails the update automatically resumes the previous one, of course that if you turn it off during the update or do strange things becomes an ornament.
However, I still do not understand what your question really is.


#8

After the device has turned into a ornament))), there is a method from the developer that would restore performance? (Example: mikrotik equipment has a “netinstall” software tool for recovering dead devices. Does the GS have something like that? Thank you.


#9

after several posts maybe I understand, you have “damaged” a level HT813 sw and do not know how to restore it?
You should open a ticket if it is under warranty and see if you pass it under warranty. Greetings.


#10

Thank you all for your help! Problem solved!


#11

Can you know how you solved?


#12

I managed to update it on another attempt, the local mode. fw: 1.0.1.2