HT813 Dial Delay


#1

I am having a problem where there is about a ten second delay from the time I dial a number to the time when there is ringing. The first ring you hear is when it has already connected to the other party as in when it shows up as a call for the person you are calling.

My setup is FreePBX Distro (FreePBX 14.0.5.25) , and the HT813 (firmware 1.0.1.2 - and also why is this the only HT adapter with an old firmware???).

Outbound route dial patterns: 1NXXNXXXXXX, (prepend 1) NXXNXXXXXX
Trunk configured sip settings:
type=peer
host=192.168.1.225
username=8145872901
secret=xxxxxxxxxxx
port=5062
disallow=all
allow=ulaw
dtmfmode=rfc2833
context=from-trunk
canreinvite=no

I don’t have it set to register, could this be a problem? In a config document I read it said not to. Both devices are running locally.

I don’t understand why I am getting such a delay. If someone has some ideas or needs some specific info please let me know.

A common issue I found is due to a DNS issue, but I checked my DNS file and only had the DHCP entries 1.1.1.1 and 1.0.0.1 (Cloudflare DNS) set which resolve. I also disabled SIP ALG in my EdgeRouter.

Thoughts?


#2

Am not sure I understand the issue exactly. but:

  1. It is not old firmware, it is the latest for this model as this model was introduced after the others. This model of ATA is the only one using FXO, so its version number system will also be different.
  2. Why is there a username and secret if using a peer trunk?
  3. What stage dial mode?
  4. To get a true understanding, there are 3 parts to the call and some form of signalling occurs between each - phone & PBX, PBX & ATA and ATA & PSTN. The time needed to accommodate the chain will always be somewhat longer than had you simply connected an analog phone to the POTS line. A capture might shed some light on some of the delays.
  5. You always dial outside the local exchange (10 and 11 digit), no 7 or 3 digit?

#3

quoto @lpneblett
also have you tried to disable the stun?


#4

rosdimiano - STUN is a tool that is used (sometimes) when traversing a NAT (RFC5389). It will only come into play when the device in question needs help in determining its public IP to aide is correct messaging formulation.

As this is an HT813 and set as a peer to a PBX where the private IP is shown and the port is 5062, it appears the device is local and not remote and the intent is to use the device’s FXO function to dial out (also the dial plan shown).

However, I am uncertain why the mention of the SIP ALG on the router or DNS resolution as nothing is mentioned or seen in the post that suggests that the HT is remote to the PBX.

Maybe there is more to the story.


#5

“rosdamiano” thanks, or better yet Damiano :slight_smile:
anyway I was wrong, and I corrected, I wanted to write disable STUN


#6

Thank you for your prompt response! I followed these directions mostly in my setup: https://wiki.freepbx.org/pages/viewpage.action?pageId=33293313

I’m was just concerned that the version number of all the others was much higher but I’m glad that it’s still current.

As far as the user/pass setting I assumed it was needed? The config page said to so I did.
I am using stage 1 dialing.

I didn’t setup the other ones as I wanted it to be as simple as possible of a dial pattern because I read that could cause a delay also in my search for answers.

I understand that there is a delay in regards to having to traverse multiple devices, but shouldn’t it be faster than ~10 seconds?

Thanks


#7

STUN is disabled.


#8

Sorry for the confusion, both the server and the HT813 are local in network. I just tried disabling the SIP ALG and checking DNS resolution as a general troubleshooting step because I found it to be a similar problem from others in my search for an answer - I understand it is likely due to the remote SIP servers in those cases where it worked, but figured it was worth a shot even though everything in my case is local.


#9

If you can get a Wireshark capture of a call that might help.