HT802 Doesn't reliably ring phones on incoming call


#1

I’m having an issue with the HT802 using VOIP.MS
I replaced a Cisco SPA2102 (2-line ATA with router) which worked fine for years. I do not use the router function. I wanted to take advantage of G722, which the Cisco doesn’t support, and that unit is at end of support.
Upon updating the HT802 with 1.0.19.11, I configured it using the guide at VOIP.MS
It seemed to work fine for a few minutes/hour, then incoming calls would not ring the analog telephones.
I ran the tests built into the HT802, and the REN was below 1. There is only one two-line analog phone connected to the HT802.
After making various changes to parameters, including SIP ports and rebooting, the unit would “work” for a bit, then revert to it’s abnormal behavior.
The symptoms are intermittent, but occur more often than not:

  1. Incoming calls do not ring the analog phone reliably.
  2. Even though the phone doesn’t audibly ring, the Caller ID of the caller usually shows on the phones display
  3. In some cases when picking up a call, only static is heard and the calling party continues to hear the ring signal on their end. The caller goes to voicemail.

NAT traversal is set to keep-alive. Codec is G722 (which Voip.ms says is Beta on their side).
I have the unit set with a static-IP address.
I don’t forward ports in my router, but maybe I should?
Almost always after a reboot of the HT802, things seem to work for minutes or an hour or so. After not receiving calls for a while, the problem seems to fairly reliably re-occur.

Wondering if anyone has had similar problems or has some insight.


#2

When incoming call not work, try calling outside.
After this try call to Ht again, if that help you have problem with routing. Try port forward to ht with voip.ms server only restriction.


#3

Tried the outgoing call then an incoming call from an outside line and it worked, but several hours later, the problem reoccurred. I gave up for the time being and switched back to my Cisco SPA 2101 which works fine (even without port forwarding). Thanks for the suggestion!


#4

In the HT, you should -

  1. Set SIP Options keep-alive to enabled with a frequency of 30 seconds
  2. Enable STUN and set a STUN server such as stun.ipvideotalk.com
  3. Have the STUN set and use the WAN port.

#5

I have the exact same problem. I’m trying the 3 steps listed here to see if that helps. Have you had any success? I really don’t want to go back to Bell.


#6

There is no advantage with that codec via an ATA - audio over a POTS service is at best a lower codec anyway.

G722 is definitely best on a Deskphone / softphone - no need to change the cisco ata for that in my opinion.


#7

There is only 1: same codec across all company.
HT will not gain any benefit as it is limited by copper line to phone (PCM).


#8

if the device gets caller id from the ata, then its getting the ringing. I found 2 options for ringing in an ATA, ring frequency and power, by default power is low, digital ringers wont care, but bells wont ring well with low power

|Ring Frequency:|20Hz default 25Hz|
|Enable High Ring Power:|No Yes|