HT802 a pain in the!



I have the HT802 set up with two lines and working fine using a fibre connection to my ISP.
But due to costs we are moving over to LTE and this is where the problems start.

The 802 connects or doesn’t connect.
Struggle to make calls and receive calls.

The 802 says “Registered” and my VoIP provider web interface shows the lines as online.
Now if I use a DLink DSL modem and provision it with the VoIP profiles it works fine.

I’ve tried all sorts of changes:
Different suggested ports or random port
Different Keep Alive options and time settings
TCP instead of UDP
Port forwarding on the router

Now the actual router doesn’t have a SIP ALG option to disable.
But I’ve got lines working as I said on the DSL router using WAN port to the LTE router.

I must say the Grandstream is far more temperamental than the Cisco SPA112.

Any other options?


probably your mobile manager has a dynamic ip, plus nattato,
moreover, mobile operators often “forbid” traffic in the SIP protocol
so it’s hard to solve

the only solution is to look for a mobile manager with a static Public IP that is not behind nat,
of course it will cost more


As I said I’ve got the VoIP working using the LTE router via a DSL modem with its VoIP service.
WAN port to LTE LAN port.
Works fine.
So there is no issue using the mobile network for VoIP calls.


I have written above the possible solutions


The info provided is a synopsis without any specifics such as -

  1. The make and model of the LTE router
  2. If the LTE router has a static or dynamic public IP that is routable
  3. If the provider is using CG-NAT.
  4. What IP is the LTE router handing out to the DSL and if not in-place what IP is the HT getting,
  5. If the public IP is dynamic, how are you handling this in the HT? Is STUN being used and is the setting in the account section also set to STUN?
  6. Does the LTE router have port forwarding or other settings available or is it really just an LTE modem that needs a router behind it?

Given the description, you have a NAT issue. This is when you register the device and all looks OK from the provider end as well as the HT, but when making a call, the messaging being sent by the HT is telling the provider to send the responses back to what is presumably a private IP, which will not work. Of course, a pcap file would tell all.


Apologies for the delay in replying.

So I have the LTE setup with my 802 working mostly.
But at times I get one line not able to make outgoing calls. Incoming is fine.
It’s random which one will give the problem.
Right now my work line can’t make calls.

The syslog error that comes up is DNS unreachable as follows:
GS_ATA: USER.DEBUG Line 1111, DNS::unreachable, same IP from cache[0] found. Mark unreachable.

Any ideas what causes this?
Voip provider blames the LTE provider and they blame the voip provider.
LTE provider is invesigating at the pace of oozing treacle.

Thank you for your time - I know how valuable it is and really appreciate you assisting.


What is being used as the DNS server?
I can only think of two things off-hand, either the DNS server is set as a FQDN and the IP cannot be resolved prior to a timeout or the speed of the query is making it to the DNS, but again too late.

It is beyond me how the LTE provider can blame the VoIP provider. The VoIP folks are completely out of the picture unless the HT was provisioned by same and the LTE people think there is a config issue. If possible, change the DNS to a public server at an IP level if not already.

Do a speed test and see what you get paying particular attention to the latency and run it multiple times as you did indicate that it is intermittent.


Well the 802 is on DHCP IP so I assume the DNS would be the LTE router.
I tried using the LTE provider DNS but that blocked registration completely so can’t be correct.

But I think you are on to something here. Likely the LTE router DNS is causing the caching error.

Jan 23 09:04:41 logger HT802 [00:0b:82:c4:ed:38] [] GS_ATA: USER.DEBUG Line 1285, DNS::isDomainCached, Fetch DNS record from DNS cache[0], host:, IP:, port: 0

Another issue I’ve asked them about is to unlock their sim card from the router supplied - but again not happening.
Then at least I could test with a different router and likely eliminate the problem.

Strange thing is the 802 worked fine all weekend and yesterday with both lines not giving any issues.


You might try and as these are Google DNS servers. Otherwise, there may be some others that you can use that might have a location closer. Do a Google search for public DNS servers in the SA.


I tried entering a static IP with DNS for Google and the device won’t register either line at all.
So I put DNS back to the router and then changed the FXS1 and FXS2 settings to use the VoIP provider server IP instead of
Then changed the DNS Mode per port to Use Configured IP.
Right now both lines are up and running so I am hopeful that this will solve the issue.


Well, good thinking to try the ITSP IP directly rather than the staying with the FQDN. Hopefully, the ITSP does not use more than one IP to handle the load.


They seem to have only the one IP address currently. But if they have issues in future I’ll work on it at that point. I must say Switch Telecom is an absolute pleasure to work with. Besides offering great call rates, they are really helpful and efficient. Plus their call quality is superb (unlike other providers).

Why I hate Grandstream?
Well, the ATA decided to revert to the previous DNS settings (A Record) on its own but without showing the changes in the web interface. So it showed as Use Configured IP but the syslog showed the DNS errors again.
Rebooting did nothing.

So I changed the settings NAPTR/SRV and back to Use Configured IP and now it’s working again.

Talk about frustrating!


It does not change on its own. Look at the config server settings and see if something is set. If you got the device from Amazon or a provider directly, the device may have a config server embedded in the firmware. Anytime you make a change, the change will be undone with a reboot.

Providers do this to prevent subscribers from making any changes and especially so should the subscriber leave their service and keep the HT thinking that they can reprogram for use elsewhere.

Some Amazon resellers buy excess inventory from these same providers and then sell it off to unwary folks. Some likely do not know, while others may not care.

What you can do is to make a change to one of the major settings and then reboot and see if same reverts to whatever was originally there. If so, then you have your answer.


Well there must be a glitch with this unit because again after a power outage it’s back to the same issue:
Jan 27 08:59:47 logger HT802 [00:0b:82:c4:ed:38] [] GS_ATA: USER.DEBUG Line 1142, DNS::unreachable, host=, found reachable IP cnt=0

Unfortunately I live in South Africa and thanks to our useless government (ANC) we have load shedding (rotational power cuts) three times a day! So the ATA is rebooting often.

I’ll have to try reflash the firmware and see if I can fix that way.