HT801 Vodafone Gigafast - Help?


Hi all,

I’m trying to configure an HT801 (latest firmware, for use on Vodafone UK’s Gigafast service. Vodafone have provided me with SIP info (Inc. Username, Password, Outbound Proxy, Registrar server). However, despite various attempts the port status always remains “Not Registered”.

Unfortunately, Vodafone only provide support for their (somewhat lacking in features) router and not for 3rd party devices such as the HT801.

Therefore, I was wondering if anyone had successfully configured the HT801 for use on the Vodafone Gigafast service?




Did you set up port forwarding or SIP Options keep-alive? Did you set up STUN for NAT?


Thanks for the reply / help.

I’ve forwarded the below UDP ports to the HT801 (Any I’ve missed?):


Also have SIP Passthrough disabled on the router and NAT Traversal set to STUN on the HT801 (Any other STUN settings required?).


Set a STUN server and you only need 5060UDP, and then the RTP port which is typically 5004.

If the router/modem is set with phone service, then you likely need to change the local SIP port to something else other than 5060 and forward.


I’ve set the STUN server to (Status page now showing “NAT: Port Restricted Cone NAT (STUN)”.

I’ve also amended the port forwarding to only 5060 UDP (Also tried using 5080 as the local SIP port) and 5004 UDP.

Unfortunately, port status remains “Not Registered”.


Looking over the log files, it appears the SIP Outbound proxy and Registrar server can’t be resolved (I only have the host names, no IPs!).


Resurrecting this conversation, as I’m in the same boat.

Vodafone fiber broadband, HT801.

I’ve got the UDP ports open for SIP and RTP (5060 & 5004) on my router
I’ve turned off anything VoiP related on the server (SIP ALG etc)
I’ve got NAT Traversal set up to use a public STUN server (

Looking at the status page on the ATA, It tells me that I’ve got full cone NAT (Stun)
I’ve entered my SIP details I got from Vodafone. These consist of
A username in the form voiXXXXXXXXX
A mixed case alphanumeric password
A value called ‘SIP’ which is the same as the username
A registration server -
A primary SIP server - xx.xx…

I’ve entered these details where I believe they should be in the FXS Port tab. But just like dzuser, my port status remains unregistered. However - something is working, as I started getting phantom calls from sip vicious (dead air on 100, 1001 etc). So much so that I’ve been in and disabled / enabled the settings mentioned here:

And that’s stopped them from ringing the phone every 30 seconds.

Any further pointers and help would be appreciated. It seems I’m close to getting it working, but no idea what the little extra is I need…


Just to inform that I have had success setting up my Vodafone account with Asterisk (using a Grandstream WP820 as a client).

I have uploaded the Asterisk config here, which should hopefully serve as a guide if you want to set it up directly on the device.


These settings will work on the HT801 and several other Grandstream devices.

On your router, you need to make sure of a few things:

  1. Either forward the subnet to the local IP of the HT801 or set Enable SIP OPTIONS/NOTIFY Keep-alive to “OPTIONS” (this should work in most circumstances).

  2. There are three options for NAT traversal. You can try using STUN, which should work. Alternatively you can enable SIP ALG on your router. Another option is to obtain a static IP from Vodafone (free of charge) and set “Use NAT IP” to your public IP.

  3. If you have problems registering, check that your router doesn’t rewrite the source ports. They must remain as specified (SIP 5065 and RTP 10000).

To test, ensure 2-way audio on both inbound and outbound calls. Ensure outbound mobile calls work.

Here are the required settings. For settings not mentioned, leave them as default. Correct Outbound proxy, User ID, password as necessary:

Primary SIP server:
Outbound proxy:
NAT Traversal: STUN (Optional)
Sip user ID: voi0123456789
Authenticate ID: voi0123456789
Authenticate password: ********
DNS mode: SRV
Register expiration: 60 minutes
Register before expiration: 15 seconds
Enable SIP Options/Noitify Keep-alive: Options (Optional)
Local SIP port: 5065
Local RTP port: 10000
Remove OBP from route header: Yes
Use NAT IP: (Your VF static IP) (Optional)
SIP User-Agent: Vox 3.0
Enable 100rel: Yes
Add Auth header on initial REGISTER: Yes
Preferred vocoder: Choice 1: PCMA
Preferred vocoder: Choice 1: G729


Hello, thank you for those settings.

  1. I could not find a way to forward the Vodafone subnet on my router to the local IP of my HT812, I could only forward ports and I did not know which type of service to specify for VoIP.
    So I use the "Enable SIP OPTIONS/NOTIFY Keep-alive to “OPTIONS”.
  2. I got a static IP from Vodafone BUT although I could make and receive calls from landlines (national and international) and mobile phones, I could NOT make any calls to any non-geographic numbers.
    The only way to fix this was to remove the “Use NAT IP” option and enable the SIP ALG on my router.
    Once I did that, everything is working fine.